FreeBSD:Pillow -- 複数の脆弱性(bc4898d5-a794-11e6-b2d3-60a44ce6887b)

high Nessus プラグイン ID 95513

言語:

概要

リモートのFreeBSDホストに1つ以上のセキュリティ関連の更新プログラムがありません。

説明

Pillowによる報告:

3.3.2より前のPillowでは、特別に細工された画像ファイルを読み取る際に、map.cで整数オーバーフローエラーが発生する可能性があります。それが、メモリの漏洩や破損につながることがあります。

3.3.2およびPIL 1.1.7(最小条件)より前のPillowでは、Storage.cのImagingNewで負の画像サイズをチェックしません。負の画像サイズは、予想よりも少ない割り当てにつながり、任意の書き込みを引き起こす可能性があります。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://pillow.readthedocs.io/en/3.4.x/releasenotes/3.3.2.html

https://github.com/python-pillow/Pillow/issues/2105

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=214410

http://www.nessus.org/u?1cd0e36a

プラグインの詳細

深刻度: High

ID: 95513

ファイル名: freebsd_pkg_bc4898d5a79411e6b2d360a44ce6887b.nasl

バージョン: 3.4

タイプ: local

公開日: 2016/12/5

更新日: 2021/1/4

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3

リスクファクター: High

Base Score: 7.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

脆弱性情報

CPE: p-cpe:/a:freebsd:freebsd:py27-pillow, p-cpe:/a:freebsd:freebsd:py33-pillow, p-cpe:/a:freebsd:freebsd:py34-pillow, p-cpe:/a:freebsd:freebsd:py35-pillow, cpe:/o:freebsd:freebsd

必要な KB アイテム: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

パッチ公開日: 2016/12/4

脆弱性公開日: 2016/9/6

参照情報

CVE: CVE-2016-9189, CVE-2016-9190