PHP 7.0.x < 7.0.14の複数の脆弱性

critical Nessus プラグイン ID 95875
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、リモートでコードが実行される脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは、7.0.14より前の7.0.xです。したがって、次の脆弱性の影響を受けます。- 空のブール要素をデコードするときに発生するext/wddx/wddx.c内のphp_wddx_push_element()関数のメモリが破損する問題のため、リモートでコードが実行される脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(CVE-2016-9935)- ext/standard/var.cスクリプトに逆シリアル化の脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、細工されたシリアル化データを介して、ターゲットホストでアプリケーションの応答を停止させたり任意のコードを実行したりする可能性があります。(CVE-2016-9936)Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

PHPバージョン7.0.14以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.0.14

プラグインの詳細

深刻度: Critical

ID: 95875

ファイル名: php_7_0_14.nasl

バージョン: 1.6

タイプ: remote

ファミリー: CGI abuses

公開日: 2016/12/15

更新日: 2019/3/27

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2016-9935

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2016/12/8

脆弱性公開日: 2016/12/6

参照情報

CVE: CVE-2016-9935, CVE-2016-9936

BID: 94846, 94849