SUSE SLES11セキュリティ更新プログラム:ImageMagick(SUSE-SU-2016:3256-1)

high Nessus プラグイン ID 96138

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このImageMagick用の更新プログラムでは、次の問題が修正されています。修正されたセキュリティ問題:

- CVE-2016-9556:ファジングにより検出されたヒープオーバーフローの可能性[bsc#1011130]

- CVE-2016-9559:ファジングにより検出されたNULLポインターアクセスの可能性[bsc#1011136]

- CVE-2016-8707:tiff deflate変換コードでのコード実行の可能性[bsc#1014159]

- CVE-2016-9773:IsPixelGrayでヒープオーバーフローの可能性[bsc#1013376]

- CVE-2016-8866:AcquireMagickMemoryでのメモリ割り当てエラーの可能性[bsc#1009318]

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

この SUSE セキュリティ更新をインストールするには、YaST online_update を使用してください。
別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterpriseソフトウェア開発キット 11-SP4:zypper in -t patch sdksp4-ImageMagick-12917=1

SUSE Linux Enterprise Server 11-SP4:zypper in -t patch slessp4-ImageMagick-12917=1

SUSE Linux Enterprise Debuginfo 11-SP4:zypper in -t patch dbgsp4-ImageMagick-12917=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1009318

https://bugzilla.suse.com/show_bug.cgi?id=1011130

https://bugzilla.suse.com/show_bug.cgi?id=1011136

https://bugzilla.suse.com/show_bug.cgi?id=1013376

https://bugzilla.suse.com/show_bug.cgi?id=1014159

https://www.suse.com/security/cve/CVE-2016-7530/

https://www.suse.com/security/cve/CVE-2016-8707/

https://www.suse.com/security/cve/CVE-2016-8866/

https://www.suse.com/security/cve/CVE-2016-9556/

https://www.suse.com/security/cve/CVE-2016-9559/

https://www.suse.com/security/cve/CVE-2016-9773/

http://www.nessus.org/u?abec5552

プラグインの詳細

深刻度: High

ID: 96138

ファイル名: suse_SU-2016-3256-1.nasl

バージョン: 3.20

タイプ: local

エージェント: unix

公開日: 2016/12/27

更新日: 2021/1/19

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libMagickCore1, cpe:/o:novell:suse_linux:11

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2016/12/23

脆弱性公開日: 2016/12/23

参照情報

CVE: CVE-2016-7530, CVE-2016-8707, CVE-2016-8866, CVE-2016-9556, CVE-2016-9559, CVE-2016-9773