SUSE SLED12 / SLES12セキュリティ更新プログラム:jasper(SUSE-SU-2017:0084-1)

high Nessus プラグイン ID 96387

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このjasper用更新プログラムでは、以下の問題を修正します。修正されたセキュリティ問題:

- CVE-2016-8654:JPC codecのQMFBコードでのヒープベースのバッファオーバーフロー(bsc#1012530)

- CVE-2016-9395:無効なjasperファイルにより、攻撃者が提供した画像によって引き起こされるライブラリ中止が発生する可能性があります。
(bsc#1010977)

- CVE-2016-9398:無効なjasperファイルにより、攻撃者が提供した画像によって引き起こされるライブラリ中止が発生する可能性があります。
(bsc#1010979)

- CVE-2016-9560:jpc_tsfb_getbands2でのスタックベースのバッファオーバーフロー(bsc#1011830)

- CVE-2016-9591:jas_matrix_destroyでのヒープのメモリ解放後使用(Use After Free)。(bsc#1015993)

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

この SUSE セキュリティ更新をインストールするには、YaST online_update を使用してください。
別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterpriseソフトウェア開発キット12-SP2:zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-27=1

SUSE Linux Enterpriseソフトウェア開発キット 12-SP1:zypper in -t patch SUSE-SLE-SDK-12-SP1-2017-27=1

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-27=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-27=1

SUSE Linux Enterprise Server 12-SP1:zypper in -t patch SUSE-SLE-SERVER-12-SP1-2017-27=1

SUSE Linux Enterprise Desktop 12-SP2::zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2017-27=1

SUSE Linux Enterprise Desktop 12-SP1:zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2017-27=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1010977

https://bugzilla.suse.com/show_bug.cgi?id=1010979

https://bugzilla.suse.com/show_bug.cgi?id=1011830

https://bugzilla.suse.com/show_bug.cgi?id=1012530

https://bugzilla.suse.com/show_bug.cgi?id=1015993

https://www.suse.com/security/cve/CVE-2016-8654/

https://www.suse.com/security/cve/CVE-2016-9395/

https://www.suse.com/security/cve/CVE-2016-9398/

https://www.suse.com/security/cve/CVE-2016-9560/

https://www.suse.com/security/cve/CVE-2016-9591/

http://www.nessus.org/u?59139d2b

プラグインの詳細

深刻度: High

ID: 96387

ファイル名: suse_SU-2017-0084-1.nasl

バージョン: 3.9

タイプ: local

エージェント: unix

公開日: 2017/1/10

更新日: 2021/1/6

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:jasper-debuginfo, p-cpe:/a:novell:suse_linux:jasper-debugsource, p-cpe:/a:novell:suse_linux:libjasper1, p-cpe:/a:novell:suse_linux:libjasper1-debuginfo, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/1/8

脆弱性公開日: 2017/2/15

参照情報

CVE: CVE-2016-8654, CVE-2016-9395, CVE-2016-9398, CVE-2016-9560, CVE-2016-9591