Apache 2.4.x < 2.4.25の複数の脆弱性(httpoxy)

high Nessus プラグイン ID 96451
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは複数の脆弱性の影響を受けます。

説明

バナーによると、リモートホストで実行しているApacheのバージョンは、2.4.25より前の2.4.xです。したがって、次の脆弱性の影響を受けます:

- CBCまたはECBの動作モード(デフォルトではAES256-CBC)で設定された暗号を使用してデータとCookieが暗号化されているため、mod_session_cryptoモジュールに欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、暗号鍵を知らなくてもパディングオラクル攻撃を通じて情報を復号して、秘密情報を漏えいする可能性があります。(CVE-2016-0736)

- クライアントエントリの割り当て中に、mod_auth_digestモジュールにサービス拒否の脆弱性があります。
認証されていないリモートの攻撃者がこれを悪用し、特別に細工された入力で共有メモリリソースを枯渇させ、サーバークラッシュを引き起こす可能性があります。(CVE-2016-2161)

- RFC 3875セクション4.1.18にしたがって名前空間の競合を適切に解決できないため、Apache HTTP Serverは「httpoxy」として知られる中間者の脆弱性の影響を受けます。HTTP_PROXY環境変数が、HTTPリクエストの「Proxy」ヘッダーの信頼できないユーザーデータに基づいて設定されます。HTTP_PROXY環境変数が、リモートプロキシサーバーを指定するために、一部のWebクライアントライブラリにより使用されます。認証されていないリモートの攻撃者がこれを悪用し、HTTPリクエストの細工された「Proxy」ヘッダーを通じて、アプリケーションの内部HTTPトラフィックを任意のプロキシサーバーにリダイレクトする可能性があります。このプロキシサーバーは、観察または操作が行われる可能性があります。
(CVE-2016-5387)

- LimitRequestFieldsディレクティブが不適切に処理されているため、mod_http2モジュールにサービス拒否の脆弱性があります。認証されていないリモートの攻撃者がこれを悪用し、HTTP/2リクエストで特別に細工されたCONTINUATIONフレームを介して無制限のリクエストヘッダーをサーバーに挿入し、メモリリソースを枯渇させる可能性があります。(CVE-2016-8740)

- ユーザーエージェントヘッダーの空白パターンが不適切に処理されているため、欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたユーザーエージェントヘッダーを使用してプログラムに誤ってリクエストシーケンスを処理させ、誤って応答を解釈させたり、キャッシュを汚染させたり、あるリクエストからのコンテンツを次の下流ユーザーエージェントに漏洩させたりする可能性があります。(CVE-2016-8743)

- mod_userdirを使用するサイトに対するHTTP応答分割攻撃を可能にするCRLFインジェクション(CVE-2016-4975)

Nessusはこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apacheバージョン2.4.25以降にアップグレードしてください。

「httpoxy」脆弱性はベンダーアドバイザリasf-httpoxy-response.txtに記載されている回避策やパッチを適用することで軽減する可能性があります。さらに、その他の脆弱性を緩和するため、影響を受けるモジュール(mod_session_crypto、mod_auth_digest、mod_http2)が使用されていないことを確認してください。

関連情報

https://httpd.apache.org/dev/dist/Announcement2.4.html

http://httpd.apache.org/security/vulnerabilities_24.html

https://github.com/apache/httpd/blob/2.4.x/CHANGES

https://www.apache.org/security/asf-httpoxy-response.txt

https://httpoxy.org

プラグインの詳細

深刻度: High

ID: 96451

ファイル名: apache_2_4_25.nasl

バージョン: 1.17

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2017/1/12

更新日: 2021/1/28

依存関係: apache_http_version.nasl, apache_http_server_nix_installed.nbin, apache_httpd_win_installed.nbin

リスク情報

CVSS スコアのソース: CVE-2016-5387

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 5.1

Temporal Score: 4

ベクトル: AV:N/AC:H/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:http_server

必要な KB アイテム: installed_sw/Apache

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2016/12/20

脆弱性公開日: 2016/7/18

参照情報

CVE: CVE-2016-0736, CVE-2016-2161, CVE-2016-4975, CVE-2016-5387, CVE-2016-8740, CVE-2016-8743, CVE-2020-11985

BID: 91816, 94650, 95076, 95077, 95078, 105093

CERT: 797896

EDB-ID: 40961