PHP 7.1.x < 7.1.1の複数の脆弱性

critical Nessus プラグイン ID 96801
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーで実行されているPHPのバージョンは、複数の脆弱性の影響を受けます。

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは、7.1.1より前の7.1.xです。したがって、次の脆弱性の影響を受けます。- シリアル化されていないオブジェクトのプロパティを処理するときトリガーされるUse-After-Freeエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工したリクエストで任意のコードを実行する可能性があります。(CVE-2016-7479)- シリアル化されていないオブジェクトが不適切に検証されているため、zend_hash.cの_zend_hash_init()関数に整数オーバーフロー状態があります。認証されていないリモートの攻撃者がこの脆弱性を悪用し、任意のコードを実行する可能性があります。(CVE-2017-5340)- TIFFとJPEGのイメージタグを処理するときにトリガーされるexif.cのexif_convert_any_to_int()関数に浮動小数点の例外の欠陥があります。認証されていないリモートの攻撃者がこれを悪用してクラッシュを起こさせ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-10158)- シリアル化されていないデータが不適切に検証されているため、var_unserializer.cのfinish_nested_data()関数に領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態や、メモリコンテンツの漏えいの原因となるクラッシュを起こす可能性があります。(CVE-2016-10161)- ユーザー指定の入力が不適切に検証されているため、wddx.cのphp_wddx_pop_element()関数に、NULLポインターデリファレンスの欠陥があります。認証されていないリモートの攻撃者がこれを悪用してクラッシュを起こさせ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-10162)- ユーザー指定の入力が不適切に検証されているため、gd_io.cに署名済みの整数オーバーフロー状態があります。認証されていないリモートの攻撃者がこれを悪用し、詳細不明な影響を与える可能性があります。- イメージが不適切に検証されているため、サービス拒否の脆弱性が、バンドルされたGDグラフィックスライブラリ(LibGD)のgd_gd2.cのgdImageCreateFromGd2Ctx()関数にあります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたイメージを介してプロセスをクラッシュさせる可能性があります。(CVE-2016-10167)- GDグラフィックスライブラリ(libgd)のgd_io.cスクリプトに整数オーバーフロー状態があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(CVE-2016-10168)- pharアーカイブが不適切に解析されているため、phar.cのphar_parse_pharfile()関数に領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用してクラッシュを起こさせ、サービス拒否状態を引き起こす可能性があります。(CVE-2017-11147)注:Nessus はこれらの問題をテストしていませんが、その代わりにアプリケーションの自己報告されたバージョン番号のみに依存しています。

ソリューション

PHPバージョン7.1.1以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.1.1

プラグインの詳細

深刻度: Critical

ID: 96801

ファイル名: php_7_1_1.nasl

バージョン: 1.9

タイプ: remote

ファミリー: CGI abuses

公開日: 2017/1/26

更新日: 2020/4/27

依存関係: php_version.nasl

リスク情報

CVSS スコアのソース: CVE-2016-7479

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2017/1/19

脆弱性公開日: 2016/12/13

参照情報

CVE: CVE-2016-7479, CVE-2017-5340, CVE-2016-10158, CVE-2016-10161, CVE-2016-10162, CVE-2016-10167, CVE-2016-10168, CVE-2017-11147

BID: 95151, 95371, 95668, 95764, 95768, 95869, 99607