SUSE SLED12 / SLES12セキュリティ更新プログラム:libxml2(SUSE-SU-2017:0380-1)

critical Nessus プラグイン ID 97015

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このlibxml2用の更新プログラムでは、次の問題が修正されます:

- CVE-2016-4658:メモリ解放後使用エラーはクラッシュにつながる可能性がありました[bsc#1005544]

- 回復モードでのxpointer.cのNULLデリファレンスを修正します[bsc#1014873]

- CVE-2016-9597:開始タグが多数含まれているXMLドキュメントが、DoSを可能にする再帰制限によって検出されないスタックのオーバーフローを引き起こした可能性があります(bsc#1017497)。
CVE-2016-9318では、既存のセットアップがオーバーライドされる可能性があるため、修正は出荷されません。信用できないXMLファイルを解析する場合は適切な対策を講じ、できるだけ新しい
-noxxeフラグを使用してください(bnc#1010675、bnc#1013930)。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

この SUSE セキュリティ更新をインストールするには、YaST online_update を使用してください。
別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterpriseソフトウェア開発キット12-SP2:zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-192=1

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-192=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-192=1

SUSE Linux Enterprise Desktop 12-SP2::zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2017-192=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1005544

https://bugzilla.suse.com/show_bug.cgi?id=1010675

https://bugzilla.suse.com/show_bug.cgi?id=1013930

https://bugzilla.suse.com/show_bug.cgi?id=1014873

https://bugzilla.suse.com/show_bug.cgi?id=1017497

https://www.suse.com/security/cve/CVE-2016-4658/

https://www.suse.com/security/cve/CVE-2016-9318/

https://www.suse.com/security/cve/CVE-2016-9597/

http://www.nessus.org/u?8b1a3b80

プラグインの詳細

深刻度: Critical

ID: 97015

ファイル名: suse_SU-2017-0380-1.nasl

バージョン: 3.6

タイプ: local

エージェント: unix

公開日: 2017/2/6

更新日: 2021/1/6

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libxml2, p-cpe:/a:novell:suse_linux:libxml2-2, p-cpe:/a:novell:suse_linux:libxml2-2-debuginfo, p-cpe:/a:novell:suse_linux:libxml2-debugsource, p-cpe:/a:novell:suse_linux:libxml2-tools, p-cpe:/a:novell:suse_linux:libxml2-tools-debuginfo, p-cpe:/a:novell:suse_linux:python-libxml2, p-cpe:/a:novell:suse_linux:python-libxml2-debuginfo, p-cpe:/a:novell:suse_linux:python-libxml2-debugsource, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/2/3

脆弱性公開日: 2016/9/25

参照情報

CVE: CVE-2016-4658, CVE-2016-9318, CVE-2016-9597