Tenable Log Correlation Engine(LCE)< 4.8.1の複数の脆弱性

critical Nessus プラグイン ID 97893
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートホストにインストールされているデータアグリゲーションアプリケーションは、複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされているTenable Log Correlation Engine(LCE)のバージョンは、4.8.1より前です。したがって、次の脆弱性による影響を受けます。- 引用符で囲まれていない属性としてテンプレートに渡された入力を適切にエスケープできないため、lib/handlebars/utils.jsスクリプトのHandlebarsライブラリに複数のクロスサイトスクリプティング(XSS)の脆弱性があります。認証されていないリモートの攻撃者がこれらの脆弱性を悪用し、特別に細工されたリクエストを通じて、ユーザーのブラウザーセッションで任意のスクリプトコードを実行する可能性があります。(CVE-2015-8861、CVE-2015-8862)- 重複した名前付きグループでネストされた後方参照を処理するときに引き起こされるPerl互換正規表現(PCRE)コンポーネントに、ヒープベースのバッファオーバーフロー状態があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(CVE-2016-1283)- XMLファイルの文字が不適切に解析されているため、parserInternals.cのlibxml2コンポーネントに領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、秘密情報を漏えいしたり、サービス拒否状態を引き起こしたりする可能性があります。(CVE-2016-1833)- 文字列をNULLで処理するときにユーザー指定の入力が不適切に検証されているため、xmlstring.cのlibxml2コンポーネントにオーバーフロー状態があります。認証されていないリモートの攻撃者が特別に細工されたPPTファイルを通じてこれを悪用し、サービス拒否状態を引き起こすしたり、任意のコードを実行する可能性があります。(CVE-2016-1834)- 複雑な名前を解析するときに引き起こされるparser.cのlibxml2コンポーネントに、複数のuse-after-freeエラーがあります。認証されていないリモートの攻撃者がこれらの問題を悪用し、特別に細工されたファイルを介して、すでに解放されているメモリをデリファレンスし、任意のコードを実行する可能性があります。(CVE-2016-1835、CVE-2016-1836)- 範囲内の文字を解析するときにユーザー入力が不適切に検証されているため、HTMLparser.cおよびxmlregexp.cのlibxml2コンポーネントに複数のヒープベースのバッファオーバーフローの状態があります。認証されていないリモートの攻撃者がこれらの問題を悪用し、特別に細工されたWebページを介して、サービス拒否状態を引き起こしたり、任意のコードを実行したりする可能性があります。(CVE-2016-1837、CVE-2016-1839、CVE-2016-1840)- parser.cのlibxml2コンポーネントに、複数の領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれらの問題を悪用し、秘密情報を漏えいしたり、サービス拒否の状態を引き起こしたりする可能性があります。(CVE-2016-1838、CVE-2016-4447)- crypto/evp/encode.cファイル内のEVP_EncodeUpdate()関数でOpenSSLコンポーネントに、ヒープバッファオーバーフロー状態があります。これは、大量の入力データを処理するときに引き起こされます。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態を引き起こす可能性があります。(CVE-2016-2105)- crypto/evp/evp_enc.cファイルのEVP_EncryptUpdate()関数でOpenSSLコンポーネントにヒープバッファオーバーフロー状態があります。これは、パーシャルブロックの同じ関数に対して以前のコールが発生する後に、大量の入力データを処理するときに引き起こされます。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態を引き起こす可能性があります。(CVE-2016-2106)- crypto/evp/e_aes_cbc_hmac_sha1.cファイル内のaesni_cbc_hmac_sha1_cipher()関数およびcrypto/evp/e_aes_cbc_hmac_sha256.cファイル内のaesni_cbc_hmac_sha256_cipher()関数に、接続がAES-CBC暗号を使用し、AES-NIがサーバーによってサポートされている場合に引き起こされる欠陥があります。中間にいる攻撃者がこれらを悪用し、パディングオラクル攻撃を通じて、ネットワークトラフィックを復号する機能を取得する可能性があります。(CVE-2016-2107)- 負の整数として表されたゼロ値のエンコードを試みた際に発生するアンダーフロー状態に起因する、リモートでコードが実行される脆弱性がASN.1エンコーダーのOpenSSLコンポーネントにあります。認証されていないリモートの攻撃者がこれを悪用し、メモリを破損させ、任意のコードを実行する可能性があります。(CVE-2016-2108)- BIOからASN.1データを読み込んだ際の、複数の詳細不明な欠陥がd2i BIO関数にあります。これは大量のメモリ割り当てを引き起こす無効なエンコーディングが原因です。認証されていないリモートの攻撃者がこれらを悪用し、リソースを枯渇させてサービス拒否状態を引き起こす可能性があります。(CVE-2016-2109)- 非常に長いASN1文字列を処理する際に、crypto/x509/x509_obj.cファイル内のX509_NAME_oneline()関数に領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、スタックメモリの内容を漏えいさせる可能性があります。(CVE-2016-2176)- (*ACCEPT)動詞を処理するときにユーザー指定の入力が不適切に検証されているため、Perl互換正規表現(PCRE)コンポーネントに、オーバーフロー状態があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(CVE-2016-3191)- リカバリモードでXMLコンテンツを処理するときに発生するparser.cのlibxml2コンポーネントに欠陥があります。認証されていないリモートの攻撃者がこれを悪用してスタックを枯渇させ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-3627)- ユーザー指定の入力が不適切に検証されているため、parser.cのlibxml2コンポーネントに欠陥があります。認証されていないリモートの攻撃者がこれを悪用してスタックを枯渇させ、サービス拒否状態を引き起こす可能性があります。(CVE-2016-3705)- 文字列書式指示子(%sや%xなど)が不適切に使用されているため、libxml2コンポーネントに書式文字列の欠陥があります。認証されていないリモートの攻撃者がこれを悪用し、サービス拒否状態または任意のコードの実行を引き起こす可能性があります。(CVE-2016-4448)- XMLデータが不適切に解析されているため、XML外部エンティティインジェクションの脆弱性がparser.cにあります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたXMLデータを通じて、任意のファイルを取得するか、サービス拒否状態を引き起こす可能性があります。(CVE-2016-4449)- リカバリモードでXMLコンテンツを処理するときに発生するxmlsave.cのlibxml2コンポーネントに領域外読み取りエラーがあります。認証されていないリモートの攻撃者がこれを悪用し、秘密情報を漏えいしたり、サービス拒否状態を引き起こしたりする可能性があります。(CVE-2016-4483)- クライアント証明書に障害が発生してもプログラムがTLSセッションを再開しようとするため、セキュリティバイパスの脆弱性がlibcurlコンポーネントにあります。認証されていないリモートの攻撃者がこれを悪用し、認証メカニズムをバイパスする可能性があります。(CVE-2016-5419)- プログラムが異なるクライアント認証情報を使用してTLSと接続してしまうため、情報漏えいの脆弱性がlibcurlコンポーネントにあります。認証されていないリモートの攻撃者がこれを悪用し、秘密性の高いクロスレルム情報を漏えいする可能性があります。(CVE-2016-5420)- libcurlコンポーネントにuse-after-freeエラーがあります。これは、処理を簡単にするための接続ポインターが適切にクリアできないときに引き起こされます。認証されていないリモートの攻撃者がこれを悪用し、すでに解放されたメモリをデリファレンスして、任意のコードを実行する可能性があります。(CVE-2016-5421)- ユーザー指定入力が不適切に検証されているため、複数の保存されているクロスサイトスクリプティング(XSS)の脆弱性があります。認証されているリモートの攻撃者がこれを悪用し、特別に細工されたリクエストを介して、ユーザーのブラウザーセッションで任意のスクリプトコードを実行する可能性があります。(CVE-2016-9261)

ソリューション

Tenable LCEをバージョン4.8.1以降にアップグレードしてください。

関連情報

https://www.tenable.com/security/tns-2016-18

https://www.openssl.org/news/secadv/20160503.txt

プラグインの詳細

深刻度: Critical

ID: 97893

ファイル名: lce_4_8_1.nasl

バージョン: 1.5

タイプ: local

ファミリー: Misc.

公開日: 2017/3/22

更新日: 2019/1/2

依存関係: lce_installed.nbin

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.8

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:tenable:log_correlation_engine

必要な KB アイテム: installed_sw/Log Correlation Engine Server

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2016/10/1

脆弱性公開日: 2015/9/7

参照情報

CVE: CVE-2015-8861, CVE-2015-8862, CVE-2016-1283, CVE-2016-1833, CVE-2016-1834, CVE-2016-1835, CVE-2016-1836, CVE-2016-1837, CVE-2016-1838, CVE-2016-1839, CVE-2016-1840, CVE-2016-2105, CVE-2016-2106, CVE-2016-2107, CVE-2016-2108, CVE-2016-2109, CVE-2016-2176, CVE-2016-3191, CVE-2016-3627, CVE-2016-3705, CVE-2016-4447, CVE-2016-4448, CVE-2016-4449, CVE-2016-4483, CVE-2016-5419, CVE-2016-5420, CVE-2016-5421, CVE-2016-9261

BID: 79825, 84810, 84992, 87940, 89744, 89746, 89752, 89757, 89760, 89854, 90013, 90856, 90864, 90865, 92292, 92306, 92309, 96434, 96436