SUSE SLES12 Security Update : apache2 (SUSE-SU-2017:0797-1)

high Nessus プラグイン ID 97912

言語:

New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

このapache2の更新では、次のセキュリティ問題が修正されます:修正されたセキュリティ問題:

- CVE-2016-0736:mod_session_cryptoデータをMACで保護し、パディングオラクル攻撃を阻止します(bsc#1016712)。

- CVE-2016-2161:mod_auth_digestへの悪意のある入力により、サーバーがクラッシュして、DoSを引き起こす可能性がありました(bsc#1016714)。

- CVE-2016-8743:プロキシチェーンの誤解釈を回避するために、新しいディレクティブ「HttpProtocolOptions Strict」を追加しました(bsc#1016715)。バグ修正:

- hcuriとhcexprの欠落しているコピーをワーカーからヘルスチェックワーカーに追加します(bsc#1019380)。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

このSUSEセキュリティ更新をインストールするには、YaST online_updateを使用してください。
別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterpriseソフトウェア開発キット12-SP2:zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-450=1

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-450=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-450=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1016715

https://www.suse.com/security/cve/CVE-2016-8743/

https://bugzilla.suse.com/show_bug.cgi?id=1016714

https://www.suse.com/security/cve/CVE-2016-2161/

https://bugzilla.suse.com/show_bug.cgi?id=1016712

https://bugzilla.suse.com/show_bug.cgi?id=1019380

https://www.suse.com/security/cve/CVE-2016-0736/

http://www.nessus.org/u?d42a4943

プラグインの詳細

深刻度: High

ID: 97912

ファイル名: suse_SU-2017-0797-1.nasl

バージョン: 3.11

タイプ: local

エージェント: unix

公開日: 2017/3/23

更新日: 2021/1/6

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.9

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:novell:suse_linux:12:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-debugsource:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-example-pages:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-prefork:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-prefork-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-utils:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-utils-debuginfo:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-worker:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:apache2-worker-debuginfo:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2017/3/22

脆弱性公開日: 2017/7/27

参照情報

CVE: CVE-2016-8743, CVE-2016-2161, CVE-2016-0736