SUSE SLED12 / SLES12セキュリティ更新プログラム:curl(SUSE-SU-2017:1042-1)

high Nessus プラグイン ID 99464

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

curl に対するこの更新では、次の問題を修正しています:修正されたセキュリティ問題:

- CVE-2016-9586:libcurl printf浮動小数点バッファオーバーフロー(bsc#1015332)

- CVE-2017-7407:curl内のtool_writeout.cのourWriteOut関数は、'%'文字で終わる--write-out引数を使用中にワークステーション画面を読み取ることによって、物理的に近接する攻撃者が、この機に乗じてプロセスメモリから秘密情報を取得する可能性がありました。これは、ヒープベースのバッファオーバーリードにつながります(bsc#1032309)。このリリースでは、新しいデフォルト暗号がアクティブになります(SUSE_DEFAULT、bsc#1027712)。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

このSUSEセキュリティ更新をインストールするには、YaST online_updateを使用してください。
別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterpriseソフトウェア開発キット12-SP2:zypper in -t patch SUSE-SLE-SDK-12-SP2-2017-609=1

SUSE Linux Enterpriseソフトウェア開発キット12-SP1:zypper in -t patch SUSE-SLE-SDK-12-SP1-2017-609=1

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-609=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-609=1

SUSE Linux Enterprise Server 12-SP1:zypper in -t patch SUSE-SLE-SERVER-12-SP1-2017-609=1

SUSE Linux Enterprise Desktop 12-SP2:zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2017-609=1

SUSE Linux Enterprise Desktop 12-SP1:zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2017-609=1

OpenStack Cloud Magnum Orchestration 7:zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-609=1

お使いのシステムを最新の状態にするには、「zypper パッチ」を使用してください。

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1015332

https://bugzilla.suse.com/show_bug.cgi?id=1027712

https://bugzilla.suse.com/show_bug.cgi?id=1032309

https://www.suse.com/security/cve/CVE-2016-9586/

https://www.suse.com/security/cve/CVE-2017-7407/

http://www.nessus.org/u?62293157

プラグインの詳細

深刻度: High

ID: 99464

ファイル名: suse_SU-2017-1042-1.nasl

バージョン: 3.9

タイプ: local

エージェント: unix

公開日: 2017/4/19

更新日: 2021/1/6

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.1

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:curl, p-cpe:/a:novell:suse_linux:curl-debuginfo, p-cpe:/a:novell:suse_linux:curl-debugsource, p-cpe:/a:novell:suse_linux:libcurl4, p-cpe:/a:novell:suse_linux:libcurl4-debuginfo, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2017/4/18

脆弱性公開日: 2017/4/3

参照情報

CVE: CVE-2016-9586, CVE-2017-7407