jQuery 1.4.0 < 1.12.0 Cross-Site Scripting

medium Web Application Scanning プラグイン ID 112434

言語:

概要

jQuery 1.4.0 < 1.12.0 のクロスサイトスクリプティング

説明

自己報告されたバージョン番号によると、jQuery は、少なくとも 1.4.0 および 1.12.0 より前、または少なくとも 1.12.4 および 3.0.0-beta1 より前です。したがって、dataType なしで実行されるクロスドメイン ajax リクエストにより、クロスサイトスクリプティングの脆弱性の影響を受ける可能性があります。

スキャナーはこれらの問題のテストを行っておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

jQuery バージョン 1.12.0 以降にアップグレードしてください。

関連情報

https://github.com/jquery/jquery/issues/2432

https://github.com/jquery/jquery/commit/f60729f3903d17917dc351f3ac87794de379b0cc

プラグインの詳細

深刻度: Medium

ID: 112434

タイプ: remote

ファミリー: Component Vulnerability

公開日: 2018/11/5

更新日: 2021/10/7

スキャン テンプレート: pci, scan

リスク情報

VPR

リスクファクター: Low

スコア: 3.8

CVSS v2

リスクファクター: Medium

Base Score: 4.3

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS スコアのソース: CVE-2015-9251

CVSS v3

リスクファクター: Medium

Base Score: 6.1

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

CVSS スコアのソース: CVE-2015-9251

脆弱性情報

CPE: cpe:2.3:a:jquery:jquery:*:*:*:*:*:*:*:*

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/1/18

脆弱性公開日: 2018/1/18

参照情報

CVE: CVE-2015-9251