Appwrite のサーバーサイドリクエストフォージェリ

high Web App Scanning プラグイン ID 114122

概要

Appwrite のサーバーサイドリクエストフォージェリ

説明

リモートにインストールされているバージョンの Appwrite には、コンポーネント「/v1/avatars/faviconhost」を通じたサーバーサイドリクエストフォージェリ (SSRF) の脆弱性が含まれています。スキャナーはこれらの問題のテストを行っておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

現在、この製品で利用可能な修正プログラムはありません。回避策として、パッチがリリースされるまで脆弱なエンドポイントへのリクエストをブロックすることが推奨されます。

参考資料

https://github.com/advisories/GHSA-hxgx-584x-vwm8

https://www.tenable.com/security/research/tra-2024-03

プラグインの詳細

深刻度: High

ID: 114122

タイプ: remote

ファミリー: Component Vulnerability

公開日: 2023/12/6

更新日: 2024/2/15

スキャン テンプレート: basic, full, pci, scan

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

Base Score: 7.8

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:N/A:N

CVSS スコアのソース: CVE-2023-27159

CVSS v3

リスクファクター: High

Base Score: 7.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

CVSS スコアのソース: CVE-2023-27159

脆弱性情報

CPE: cpe:2.3:a:appwrite:appwrite:*:*:*:*:*:*:*:*

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2021/5/14

脆弱性公開日: 2021/5/19

参照情報

CVE: CVE-2023-27159, CVE-2024-1063