PHP 5.6.x < 5.6.9 Multiple Vulnerabilities

critical Web Application Scanning プラグイン ID 98832

言語:

概要

PHP 5.6.x < 5.6.9の複数の脆弱性

説明

バナーによると、リモート Web サーバーで実行している PHP 5.6.x のバージョンは、5.6.9 より前です。したがって、以下の複数の脆弱性による影響を受けます。

- - NULL バイトを含まれているパス名の使用に関連する複数の欠陥が存在します。リモートの攻撃者がこれらの欠陥を悪用し、「\\0」文字を安全なファイル拡張機能と組み合わせることで、アクセス制限をバイパスする恐れがあります。これは以前修正されましたが、バージョン5.4+での回帰により再導入しました。(CVE-2006-7243、CVE-2015-4025)

- ユーザー指定の入力の不適切な検証により、ftp.c の ftp_genlist() 関数に、整数オーバーフロー状態が存在します。リモートの攻撃者がこれを悪用して、サービス拒否状態またはリモートコードの実行につながるヒープベースのバッファオーバーフローを引き起こす可能性があります。(CVE-2015-4022)

- HTTP リクエストでマルチパート/フォームデータを不適切に処理しているため、rfc1867.c 内の multipart_buffer_headers() 関数に欠陥が存在します。リモートの攻撃者がこの欠陥を悪用し、サービス拒否状態につながる CPU リソースの消費を引き起こす恐れがあります。(CVE-2015-4024)

- 「\\x00」文字に遭遇するとパス名を切り捨てる pcntl_exec 実装の欠陥が原因で、セキュリティバイパス脆弱性が存在します。リモートの攻撃者が細工された最初の引数を介してこれを悪用し、意図された拡張制限をバイパスし任意のファイルを実行する恐れがあります。(CVE-2015-4026)

- ユーザー指定の入力の不適切な検証により、xsltprocessor.c の xsl_ext_function_php() 関数に、NULL ポインターデリファレンスの欠陥が存在します。リモートの攻撃者がこれを悪用することで、サービス拒否状態を引き起こす可能性があります。

注意 : スキャナーはこの問題のテストを行っておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

PHP バージョン 5.6.9以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-5.php#5.6.9

プラグインの詳細

深刻度: Critical

ID: 98832

タイプ: remote

ファミリー: Component Vulnerability

公開日: 2019/1/9

更新日: 2021/11/19

スキャン テンプレート: pci, api, scan

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2015-4022

CVSS v3

リスクファクター: Critical

Base Score: 9.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVSS スコアのソース: CVE-2006-7243

脆弱性情報

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2011/1/18

脆弱性公開日: 2011/1/18

参照情報

CVE: CVE-2015-4021, CVE-2015-4022, CVE-2015-4024, CVE-2015-4026, CVE-2006-7243, CVE-2015-4025