PHP 7.1.x < 7.1.17 Multiple Vulnerabilities

high Web Application Scanning プラグイン ID 98860

言語:

概要

PHP 7.1.x < 7.1.17の複数の脆弱性

説明

バナーによると、リモートのWebサーバーで実行されているPHPのバージョンは7.1.17より前の7.1.xです。したがって、複数の脆弱性の影響を受けます。

スキャナーはこれらの問題のテストを行っておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

PHP バージョン 7.1.17以降にアップグレードしてください。

関連情報

http://php.net/ChangeLog-7.php#7.1.17

プラグインの詳細

深刻度: High

ID: 98860

タイプ: remote

ファミリー: Component Vulnerability

公開日: 2019/1/9

更新日: 2021/10/7

スキャン テンプレート: pci, api, scan

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2018-10549

CVSS v3

リスクファクター: High

Base Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

CVSS スコアのソース: CVE-2018-10549

脆弱性情報

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/4/29

脆弱性公開日: 2018/4/29

参照情報

CVE: CVE-2018-10545, CVE-2018-10546, CVE-2018-10547, CVE-2018-10548, CVE-2018-10549

CWE: 200, 79, 125, 476, 400

WASC: Cross-Site Scripting, Information Leakage, Denial of Service

OWASP: 2010-A2, 2013-A3, 2013-A9, 2017-A7, 2017-A9, 2017-A6, 2013-A5, 2010-A6, 2021-A6, 2021-A1, 2021-A3

OWASP API: 2019-API7

HIPAA: 164.306(a)(1), 164.306(a)(2)

DISA STIG: APSC-DV-002630, APSC-DV-000460, APSC-DV-002490, APSC-DV-002590, APSC-DV-002400

OWASP ASVS: 4.0.2-14.2.1, 4.0.2-8.3.4, 4.0.2-5.3.3

PCI-DSS: 3.2-2.2, 3.2-6.2, 3.2-6.5.8, 3.2-6.5.2, 3.2-6.5.7, 3.2-6.5.1

ISO: 27001-A.14.2.5, 27001-A.12.6.1

CAPEC: 116, 13, 169, 22, 224, 285, 287, 290, 291, 292, 293, 294, 295, 296, 297, 298, 299, 300, 301, 302, 303, 304, 305, 306, 307, 308, 309, 310, 312, 313, 317, 318, 319, 320, 321, 322, 323, 324, 325, 326, 327, 328, 329, 330, 472, 497, 508, 573, 574, 575, 576, 577, 59, 60, 616, 643, 646, 651, 79, 209, 588, 591, 592, 63, 85, 540, 147, 197, 492

NIST: sp800_53-CM-6b, sp800_53-SI-10, sp800_53-SC-5, sp800_53-SI-15, sp800_53-SI-16