JQuery 1.6.x <1.6.3のXSS

medium Nessus プラグイン ID 106656

概要

リモートのWebサーバーは、クロスサイトスクリプティング脆弱性の影響を受けます。

説明

スクリプトで自己報告されたバージョンによると、リモートのWebサーバーでホストされているJQueryのバージョンは1.6.3より前の1.6.xです。したがって、location.hashを使用して要素を選択するとき、クロスサイトスクリプティングの脆弱性の影響を受けます。

ソリューション

1.6.3以降のJQueryバージョンにアップグレードしてください。

関連情報

https://blog.jquery.com/2011/09/01/jquery-1-6-3-released/

プラグインの詳細

深刻度: Medium

ID: 106656

ファイル名: jquery_1_6_3.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses : XSS

公開日: 2018/2/7

更新日: 2019/5/3

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: CVE-2011-4969

VPR

リスクファクター: Low

スコア: 1.6

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 4.7

Temporal Score: 4.1

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

必要な KB アイテム: Settings/ParanoidReport, installed_sw/jquery

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2011/9/1

脆弱性公開日: 2011/9/1

参照情報

CVE: CVE-2011-4969

BID: 58458