JQuery 1.x <1.12.0/2.x <2.2.0のXSS

medium Nessus プラグイン ID 106657

概要

リモートのWebサーバーは、クロスサイトスクリプティング脆弱性の影響を受けます。

説明

リモートのWebサーバーでホストされているJQueryライブラリのバージョンは、1.12.0より前の1.xまたは2.2.0より前の2.xです。したがって、location.hostを使用して要素を選択するとき、クロスサイトスクリプティングの脆弱性の影響を受けます。

ソリューション

JQueryバージョン1.12.0以降にアップグレードしてください。

関連情報

https://blog.jquery.com/2016/01/08/jquery-2-2-and-1-12-released/

プラグインの詳細

深刻度: Medium

ID: 106657

ファイル名: jquery_2_2_0.nasl

バージョン: 1.6

タイプ: remote

ファミリー: CGI abuses : XSS

公開日: 2018/2/7

更新日: 2020/11/24

構成: パラノイドモードの有効化

リスク情報

CVSS スコアのソース: manual

CVSS スコアの根本的理由: Score based on analysis of the vendor advisory.

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.7

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:H/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 4.7

Temporal Score: 4.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:jquery:jquery

必要な KB アイテム: Settings/ParanoidReport, installed_sw/jquery

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2015/9/10

脆弱性公開日: 2015/6/15