CKEditor 4.5.11 <4.9.2のEnhanced ImageプラグインXSS

medium Nessus プラグイン ID 109403
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWebサーバーは、クロスサイトスクリプティング脆弱性の影響を受けるスクリプトをホストします。

説明

リモートホストにインストールされているバージョンのCKEditorは、クロスサイトスクリプティングの脆弱性に影響を受けます。含まれている「Enhanced Image」プラグインにより、CKEditorではユーザー指定の入力を適切にサニタイズできなくなります。認証されていないリモートの攻撃者がこれを悪用し、任意のHTMLおよびスクリプトコードをユーザーのブラウザーに挿入して、影響を受けるサイトのセキュリティコンテキスト内で実行させる可能性があります。

ソリューション

CKEditorバージョン4.9.2以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?be1255cc

プラグインの詳細

深刻度: Medium

ID: 109403

ファイル名: ckeditor_image2_xss.nasl

バージョン: 1.4

タイプ: remote

ファミリー: CGI abuses : XSS

公開日: 2018/4/27

更新日: 2020/3/27

依存関係: http_version.nasl

リスク情報

CVSS スコアのソース: CVE-2018-9861

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:ckeditor:ckeditor

必要な KB アイテム: www/PHP

除外される KB アイテム: Settings/disable_cgi_scanning

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/4/17

脆弱性公開日: 2018/4/17

参照情報

CVE: CVE-2018-9861

BID: 103924