CentOS 7:java-1.7.0-openjdk(CESA-2018:1278)

medium Nessus プラグイン ID 110244
New! Vulnerability Priority Rating (VPR)

Tenable では、すべての脆弱性に対して動的な VPR が計算されます。VPR は脆弱性の情報を、脅威インテリジェンスや機械学習アルゴリズムと組み合わせて、攻撃時に最も悪用される可能性の高い脆弱性を予測します。詳細は、 「VPR とは何で、CVSS とはどう違うのか」を参照してください。

VPR スコア : 8.1

概要

リモートのCentOSホストに1つ以上のセキュリティ更新プログラムがありません。

説明

java-1.7.0-openjdkの更新プログラムが、Red Hat Enterprise Linux 7で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。java-1.7.0-openjdkパッケージには、OpenJDK 7 Java Runtime EnvironmentおよびOpenJDK 7 Javaソフトウェア開発キットが含まれています。セキュリティ修正プログラム:*OpenJDK:リファレンスクローンの不適切な処理により、サンドボックスバイパスが発生する脆弱性(Hotspot、8192025)(CVE-2018-2814)*OpenJDK:JCEKSキーストアからの無制限のデータ逆シリアル化(セキュリティ、8189997)(CVE-2018-2794)*OpenJDK:複数のクラスの逆シリアル化時における不十分な整合性チェック(セキュリティ、8189977)(CVE-2018-2795)*OpenJDK:PriorityBlockingQueueにおける逆シリアル化中の無制限メモリ割り当て(並行処理、8189981)(CVE-2018-2796)*OpenJDK:TabularDataSupportにおける逆シリアル化中の無制限メモリ割り当て(JMX、8189985)(CVE-2018-2797)*OpenJDK:Containerにおける逆シリアル化中の無制限のメモリ割り当て(AW​​T、8189989)(CVE-2018-2798)*OpenJDK:NamedNodeMapImplにおける逆シリアル化中の無制限のメモリ割り当て(JAXP、8189993)(CVE-2018-2799)*OpenJDK:デフォルトで有効になっているRMI HTTPトランスポート(RMI、8193833)(CVE-2018-2800)*OpenJDK:StubIORImplにおける逆シリアル化中の無制限のメモリ割り当て(シリアル化、8192757)(CVE-2018-2815)*OpenJDK:JARマニフェストにおける不適切なセクションのマージ(セキュリティ、8189969)(CVE-2018-2790)影響、CVSSスコア、その他の関連情報を含むセキュリティの問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。

ソリューション

影響を受けるjava-1.7.0-openjdkパッケージを更新してください。

関連情報

http://www.nessus.org/u?f4b6a259

プラグインの詳細

深刻度: Medium

ID: 110244

ファイル名: centos_RHSA-2018-1278.nasl

バージョン: 1.8

タイプ: local

エージェント: unix

公開日: 2018/5/31

更新日: 2019/12/31

依存関係: ssh_get_info.nasl

リスク情報

リスクファクター: Medium

VPR スコア: 8.1

CVSS スコアのソース: CVE-2018-2814

CVSS v2.0

Base Score: 5.1

ベクトル: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

脆弱性の情報

CPE: cpe:2.3:o:centos:centos:7:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:java-1.7.0-openjdk:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:java-1.7.0-openjdk-demo:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:java-1.7.0-openjdk-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:java-1.7.0-openjdk-javadoc:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:java-1.7.0-openjdk-src:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:java-1.7.0-openjdk-accessibility:*:*:*:*:*:*:*, p-cpe:2.3:a:centos:centos:java-1.7.0-openjdk-headless:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

パッチ公開日: 2018/5/30

脆弱性公開日: 2018/4/19

参照情報

CVE: CVE-2018-2790, CVE-2018-2794, CVE-2018-2795, CVE-2018-2796, CVE-2018-2797, CVE-2018-2798, CVE-2018-2799, CVE-2018-2800, CVE-2018-2814, CVE-2018-2815

RHSA: 2018:1278