KB4284880: Windows 10バージョン1607およびWindows Server 2016の2018年6月のセキュリティ更新プログラム

high Nessus プラグイン ID 110491
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWindowsホストは、複数の脆弱性の影響を受けます。

説明

リモートのWindowsホストにセキュリティ更新プログラム4284880がありません。
したがって、以下の複数の脆弱性による影響を受けます。

- HID(ヒューマンインターフェイスデバイス)Parser Libraryドライバーがメモリでオブジェクトを不適切に処理するとき、権限昇格の脆弱性があります。この脆弱性の悪用に成功した攻撃者が、昇格したコンテキストでプロセスを実行する可能性があります。(CVE-2018-8169)

- Windows Media Foundationがメモリ内のオブジェクトを不適切に処理する場合に、メモリ破損の脆弱性があります。
脆弱性の悪用に成功した攻撃者が、完全なユーザー権限でプログラムのインストール、データの表示・変更・削除、新しいアカウントの作成などを行う可能性があります。攻撃者がこの脆弱性を悪用する方法は複数あります。たとえば、ユーザーを誘導して巧妙に作りこまれたドキュメントを開かせたり、悪意のあるWebページにアクセスさせたりする可能性があります。セキュリティ更新プログラムは、Windows Media Foundationがメモリでオブジェクトを処理する方法を修正することにより脆弱性に対応します。(CVE-2018-8251)

- Windowsがメモリ内のオブジェクトを不適切に処理する場合に、サービス拒否の脆弱性があります。この脆弱性の悪用に成功した攻撃者が、ターゲットシステムの応答を停止させる可能性があります。(CVE-2018-8205)

- Windows GDIコンポーネントがメモリの内容を不適切に開示するとき、情報漏洩の脆弱性があります。この脆弱性の悪用に成功した攻撃者は、情報を取得してユーザーシステムをさらに侵害する可能性があります。攻撃者がこの脆弱性を悪用する方法は複数あり、ユーザーを誘導して巧妙に作りこまれたドキュメントを開かせたり、信頼できないWebページにアクセスさせたりする可能性があります。
セキュリティ更新プログラムは、Windows GDIコンポーネントがメモリ内でオブジェクトを処理する方法を修正することにより、この脆弱性に対応します。(CVE-2018-8239)

- HTTPプロトコルスタック(Http.sys)がメモリでオブジェクトを不適切に処理するとき、リモートでコードが実行される脆弱性があります。この脆弱性の悪用に成功した攻撃者が、任意のコードを実行し、影響を受けるシステムを乗っ取る可能性があります。(CVE-2018-8231)

- Microsoft Edgeがメモリ内のオブジェクトを不適切に処理するとき、情報漏えいの脆弱性があります。この脆弱性の悪用に成功した攻撃者は、情報を取得してユーザーシステムをさらに侵害する可能性があります。(CVE-2018-8234)

- HTTP.sysが特別に細工されたHTTP 2.0リクエストを不適切に解析するとき、サービス拒否の脆弱性がHTTP 2.0プロトコルスタック(HTTP.sys)にあります。脆弱性の悪用に成功した攻撃者が、サービス拒否状態を作りだし、標的のシステムの応答を停止させる可能性があります。(CVE-2018-8226)

- ChakraスクリプトエンジンがMicrosoft Edgeのメモリでオブジェクトを処理する方法に、リモートコード実行脆弱性があります。この脆弱性により、攻撃者が現在のユーザーのコンテキストで任意のコードを実行し、メモリを破損させる可能性があります。この脆弱性の悪用に成功した攻撃者が、現在のユーザーと同じユーザー権限を取得する可能性があります。(CVE-2018-8229)

- スクリプトエンジンがInternet Explorerのメモリでオブジェクトを処理する方法に、リモートでコードが実行される脆弱性があります。この脆弱性により、攻撃者が現在のユーザーのコンテキストで任意のコードを実行し、メモリを破損させる可能性があります。この脆弱性の悪用に成功した攻撃者が、現在のユーザーと同じユーザー権限を取得する可能性があります。
(CVE-2018-8267)

- Windowsカーネルがメモリ内のオブジェクトを不適切に処理する場合に、情報漏洩の脆弱性があります。この脆弱性の悪用に成功した攻撃者は、情報を取得してユーザーシステムをさらに侵害する可能性があります。(CVE-2018-8207)

- NTFSが不適切にアクセスをチェックするとき、権限昇格の脆弱性があります。この脆弱性の悪用に成功した攻撃者が、昇格したコンテキストでプロセスを実行する可能性があります。(CVE-2018-1036)

- DNS応答を適切に処理しないとき、リモートコード実行の脆弱性がWindowsドメインネームシステム(DNS)DNSAPI.dllにあります。この脆弱性を悪用した攻撃者が、Local System Accountのコンテキストで任意のコードを実行する可能性があります。(CVE-2018-8225)

- Microsoft Edgeが異なるオリジンの要求を不適切に処理する場合、セキュリティ機能をバイパスする脆弱性が存在します。この脆弱性により、Microsoft Edgeは同一オリジンポリシー(SOP)制限をバイパスし、本来であれば無視されるべき要求を許可します。脆弱性の悪用に成功した攻撃者が、本来であれば制限されるべきデータを送信するようにブラウザーに強制する可能性があります。(CVE-2018-8235)

- Windowsが管理者のワイヤレスLANプロファイルにアクセスすることを通常のユーザーに許可するとき、情報漏えいの脆弱性があります。脆弱性の悪用に成功した認証された攻撃者が、ワイヤレスネットワークのパスワードが含まれる管理者のワイヤレスLANプロファイルにアクセスする可能性があります。攻撃者が影響を受けたシステムにログオンし、特定のコマンドを実行する必要があります。セキュリティ更新プログラムは、WindowsがワイヤレスLANプロファイルへのアクセス許可の実施方法を変更することにより、脆弱性に対応します。(CVE-2018-8209)

- Internet Explorerがメモリでオブジェクトに不適切にアクセスするとき、リモートでコードが実行される脆弱性があります。
この脆弱性により、攻撃者が現在のユーザーのコンテキストで任意のコードを実行し、メモリを破損させる可能性があります。この脆弱性の悪用に成功した攻撃者が、現在のユーザーと同じユーザー権限を取得する可能性があります。(CVE-2018-0978)

- Windows Hyper-V命令エミュレーションが権限レベルを適切に実施できないとき、権限昇格の脆弱性があります。この脆弱性の悪用に成功した攻撃者が、標的のゲストオペレーティングシステムで昇格した権限を取得する可能性があります。ホストオペレーティングシステムはこの攻撃に対して脆弱ではありません。この脆弱性だけでは、任意のコードが実行されることはありません。ただし、この脆弱性が1つまたは複数の脆弱性(リモートでコードが実行される脆弱性と権限昇格の脆弱性など)との組み合わせで使用され、実行時に昇格した権限を利用されることがあります。更新プログラムは、Windows Hyper-V命令エミュレーションが権限を実施する方法を修正することにより、脆弱性に対応します。
(CVE-2018-8219)

- セキュリティ機能バイパスの脆弱性がDevice Guardにあるため、攻撃者がWindows PowerShellセッションに悪意のあるコードを挿入する可能性があります。この脆弱性の悪用に成功した攻撃者は、信頼できるPowerShellプロセスにコードを挿入し、ローカルマシンにあるDevice Guardのコード整合性ポリシーをバイパスする可能性があります。
(CVE-2018-8201、CVE-2018-8212、CVE-2018-8215、CVE-2018-8216、CVE-2018-8217、CVE-2018-8221)

- Microsoft Edgeがメモリでオブジェクトに不適切にアクセスするとき、リモートでコードが実行される脆弱性があります。
この脆弱性により、攻撃者が現在のユーザーのコンテキストで任意のコードを実行し、メモリを破損させる可能性があります。この脆弱性の悪用に成功した攻撃者が、現在のユーザーと同じユーザー権限を取得する可能性があります。(CVE-2018-8236)

- Windows Code Integrity Moduleがハッシュする方法に、サービス拒否の脆弱性があります。脆弱性の悪用に成功した攻撃者が、システムの応答を停止させる可能性があります。サービス拒否状態では、攻撃者がコードを実行したり、ユーザー権限を昇格させたりすることはできません。ただし、サービス拒否状態により、許可されたユーザーがシステムリソースを使用できなくなる可能性があります。攻撃者が、特別に細工されたファイルをWebサイトまたはSMB共有でホストする可能性があります。
また、攻撃者が、脆弱性を悪用できる特別に細工されたコンテンツを追加することにより、侵害されたWebサイト、あるいは、ユーザー提供のコンテンツや広告を受け入れるまたはホストするWebサイトを利用する可能性があります。ただしどの場合でも、攻撃者が制御するコンテンツをユーザーに対して強制的に表示する方法はありません。代わりに、攻撃者は通常、電子メールやインスタントメッセージを介してユーザーに操作をするように誘導するか、電子メールの添付ファイルを開くように誘導します。セキュリティ更新プログラムは、コード整合性モジュールがハッシュする方法を変更することにより、この脆弱性に対応します。
(CVE-2018-1040)

- Windowsがメモリ内のオブジェクトを不適切に処理するとき、リモートでコードが実行される脆弱性があります。これらの脆弱性を悪用した攻撃者が、影響を受けるシステムを乗っ取る可能性があります。(CVE-2018-8210、CVE-2018-8213)

- WindowsカーネルAPIがアクセス許可を適用する方法に、権限昇格の脆弱性があります。脆弱性の悪用に成功した攻撃者が、プロセスを偽装する、クロスプロセス通信を注入する、またはシステム機能を中断する可能性があります。
(CVE-2018-0982)

- デスクトップブリッジが仮想レジストリを適切に管理していないとき、権限昇格の脆弱性がWindowsにあります。この脆弱性の悪用に成功した攻撃者が、カーネルモードで任意のコードを実行する可能性があります。その後、攻撃者は、完全なユーザー権限で、プログラムのインストール、データの表示・変更・削除、または新規アカウントの作成を実行する可能性があります。(CVE-2018-8208、CVE-2018-8214)

ソリューション

累積的な更新プログラムKB4284880を適用してください。

関連情報

http://www.nessus.org/u?3dae2364

プラグインの詳細

深刻度: High

ID: 110491

ファイル名: smb_nt_ms18_jun_4284880.nasl

バージョン: 1.6

タイプ: local

エージェント: windows

公開日: 2018/6/12

更新日: 2020/8/18

依存関係: smb_check_rollup.nasl, smb_hotfixes.nasl, ms_bulletin_checks_possible.nasl

リスク情報

CVSS スコアのソース: CVE-2018-8231

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 7.3

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:microsoft:windows, cpe:/a:microsoft:edge

必要な KB アイテム: SMB/MS_Bulletin_Checks/Possible

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/6/12

脆弱性公開日: 2018/6/12

参照情報

CVE: CVE-2018-0978, CVE-2018-0982, CVE-2018-1036, CVE-2018-1040, CVE-2018-8169, CVE-2018-8201, CVE-2018-8205, CVE-2018-8207, CVE-2018-8208, CVE-2018-8209, CVE-2018-8210, CVE-2018-8212, CVE-2018-8213, CVE-2018-8214, CVE-2018-8215, CVE-2018-8216, CVE-2018-8217, CVE-2018-8219, CVE-2018-8221, CVE-2018-8225, CVE-2018-8226, CVE-2018-8229, CVE-2018-8231, CVE-2018-8234, CVE-2018-8235, CVE-2018-8236, CVE-2018-8239, CVE-2018-8251, CVE-2018-8267

BID: 104328, 104331, 104333, 104334, 104336, 104337, 104338, 104340, 104343, 104353, 104356, 104360, 104361, 104364, 104369, 104373, 104379, 104382, 104389, 104391, 104392, 104393, 104394, 104395, 104398, 104401, 104404, 104406, 104407

MSKB: 4284880

MSFT: MS18-4284880