Scientific Linux セキュリティ更新: SL7.x x86_64のghostscript(20181217)

critical Nessus プラグイン ID 119883

概要

リモートのScientific Linuxホストに1つ以上のセキュリティ更新プログラムがありません。

説明

セキュリティ修正プログラム:

- ghostscript: pagedevice置換に不適切なfreeロジック(699664)(CVE-2018-16541)

- ghostscript: 例外処理中にスタックが足りなくなったときの不正な「権限の復元」チェック(CVE-2018-16802)

- ghostscript: ユーザーによる書き込みが可能なエラー例外テーブル(CVE-2018-17183)

- ghostscript: 保存された実行スタックは演算子配列が漏洩する可能性がある(CVE-2018-17183に対する不完全な修正)(CVE-2018-17961)

- ghostscript: 保存された実行スタックは演算子配列が漏洩する可能性がある(CVE-2018-18073)

- ghostscript: 1Policy演算子によりサンドボックス保護メカニズムのバイパスが可能になる(CVE-2018-18284)

- ghostscript: setpatternおける型の取り違え(700141)(CVE-2018-19134)

- ghostscript: psi/zdevice.cのzsetdevice関数のセキュリティチェックが不適切に実装されている(CVE-2018-19409)

- ghostscript: aesdecode演算子における初期化されていないメモリアクセス(699665)(CVE-2018-15911)

バグ修正プログラム:

- ghostscript-9.07-31.el7_6.1ではシェーディングオブジェクトの処理中にリグレッションが発生し、「Dropping incorrect smooth shading object(不適切なスムーズシェーディングオブジェクトを削除しました)」という警告が表示されることがわかりました。この更新プログラムでは、このリグレッションが修正され、前述の問題は発生しなくなりました。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.nessus.org/u?f8823a33

プラグインの詳細

深刻度: Critical

ID: 119883

ファイル名: sl_20181217_ghostscript_on_SL7_x.nasl

バージョン: 1.8

タイプ: local

エージェント: unix

公開日: 2018/12/27

更新日: 2020/8/21

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 8.1

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:fermilab:scientific_linux:ghostscript, p-cpe:/a:fermilab:scientific_linux:ghostscript-cups, p-cpe:/a:fermilab:scientific_linux:ghostscript-debuginfo, p-cpe:/a:fermilab:scientific_linux:ghostscript-devel, p-cpe:/a:fermilab:scientific_linux:ghostscript-doc, p-cpe:/a:fermilab:scientific_linux:ghostscript-gtk, x-cpe:/o:fermilab:scientific_linux

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2018/12/17

脆弱性公開日: 2018/8/28

参照情報

CVE: CVE-2018-15911, CVE-2018-16541, CVE-2018-16802, CVE-2018-17183, CVE-2018-17961, CVE-2018-18073, CVE-2018-18284, CVE-2018-19134, CVE-2018-19409

IAVB: 2019-B-0081-S