CentOS 7:systemd(CESA-2019:0049)

critical Nessus プラグイン ID 121192
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのCentOSホストに1つまたは複数のセキュリティ更新プログラムがありません。

説明

systemdの更新プログラムが、Red Hat Enterprise Linux 7で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。systemdパッケージには、Linux用のシステムおよびサービスのマネージャーであるsystemdが含まれます。このsystemdはSysVおよびLSB initスクリプトと互換性があります。これは積極的な並列化機能を提供し、起動サービスにソケットとD-Busの有効化を使用し、デーモンのオンデマンド起動を提供し、Linux cgroupsを使用したプロセスを記録します。また、システム状態のスナップショットと復元をサポートし、マウントポイントと自動マウントポイントを維持し、複雑なトランザクション依存ベースのサービス制御ロジックを実装します。これはsysvinitの完全な互換品としても機能します。セキュリティ修正プログラム:* systemd:systemd-networkd dhcpv6オプション処理での領域外ヒープ書き込み(CVE-2018-15688)* systemd:長いcmdlineを持つコマンドからsyslogを呼び出した際のスタックオーバーフロー(CVE-2018-16864)* systemd: stack overflow when receiving many journald entries(CVE-2018-16865)影響、CVSSスコア、その他の関連情報を含むセキュリティの問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。Red Hatは、CVE-2018-15688を報告してくれたUbuntu Security Teamと、CVE-2018-16864およびCVE-2018-16865を報告してくれたQualys Research Labsに感謝の意を表します。アップストリームは、Felix Wilhelm氏(Google)をCVE-2018-15688の最初の報告者として認めています。

ソリューション

影響を受けるsystemdパッケージを更新してください。

関連情報

http://www.nessus.org/u?55d760dc

プラグインの詳細

深刻度: Critical

ID: 121192

ファイル名: centos_RHSA-2019-0049.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/1/16

更新日: 2019/12/31

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2018-15688

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:libgudev1, p-cpe:/a:centos:centos:libgudev1-devel, p-cpe:/a:centos:centos:systemd, p-cpe:/a:centos:centos:systemd-devel, p-cpe:/a:centos:centos:systemd-journal-gateway, p-cpe:/a:centos:centos:systemd-libs, p-cpe:/a:centos:centos:systemd-networkd, p-cpe:/a:centos:centos:systemd-python, p-cpe:/a:centos:centos:systemd-resolved, p-cpe:/a:centos:centos:systemd-sysv, cpe:/o:centos:centos:7

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/1/15

脆弱性公開日: 2018/10/26

参照情報

CVE: CVE-2018-15688, CVE-2018-16864, CVE-2018-16865

RHSA: 2019:0049