Debian DLA-1635-1: sssdのセキュリティ更新

medium Nessus プラグイン ID 121233
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートの Debian ホストにセキュリティ更新プログラムがありません。

説明

sssdに脆弱性が見つかりました。ユーザーがホームディレクトリを設定しないで構成されている場合、sssdは「''」(空の文字列/ホームディレクトリなし)の代わりに「/」(rootディレクトリ)を返します。これは、chroot()経由などでユーザーのファイルシステムアクセスをホームディレクトリ内に制限するサービスに影響を及ぼす可能性があります。

Debian 8「Jessie」では、この問題はバージョン1.11.7-3+deb8u2で修正されました。

sssdパッケージをアップグレードすることをお勧めします。

注: Tenable Network Securityは、前述の記述ブロックをDLAセキュリティアドバイザリーから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

影響を受けるパッケージをアップグレードしてください。

関連情報

https://lists.debian.org/debian-lts-announce/2019/01/msg00011.html

https://packages.debian.org/source/jessie/sssd

プラグインの詳細

深刻度: Medium

ID: 121233

ファイル名: debian_DLA-1635.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/1/18

更新日: 2021/1/11

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Low

Base Score: 2.7

Temporal Score: 2

ベクトル: AV:A/AC:L/Au:S/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.2

Temporal Score: 4.5

ベクトル: CVSS:3.0/AV:A/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:libipa-hbac-dev, p-cpe:/a:debian:debian_linux:libipa-hbac0, p-cpe:/a:debian:debian_linux:libnss-sss, p-cpe:/a:debian:debian_linux:libpam-sss, p-cpe:/a:debian:debian_linux:libsss-idmap-dev, p-cpe:/a:debian:debian_linux:libsss-idmap0, p-cpe:/a:debian:debian_linux:libsss-nss-idmap-dev, p-cpe:/a:debian:debian_linux:libsss-nss-idmap0, p-cpe:/a:debian:debian_linux:libsss-sudo, p-cpe:/a:debian:debian_linux:python-libipa-hbac, p-cpe:/a:debian:debian_linux:python-libsss-nss-idmap, p-cpe:/a:debian:debian_linux:python-sss, p-cpe:/a:debian:debian_linux:sssd, p-cpe:/a:debian:debian_linux:sssd-ad, p-cpe:/a:debian:debian_linux:sssd-ad-common, p-cpe:/a:debian:debian_linux:sssd-common, p-cpe:/a:debian:debian_linux:sssd-dbus, p-cpe:/a:debian:debian_linux:sssd-ipa, p-cpe:/a:debian:debian_linux:sssd-krb5, p-cpe:/a:debian:debian_linux:sssd-krb5-common, p-cpe:/a:debian:debian_linux:sssd-ldap, p-cpe:/a:debian:debian_linux:sssd-proxy, p-cpe:/a:debian:debian_linux:sssd-tools, cpe:/o:debian:debian_linux:8.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/1/17

脆弱性公開日: 2019/1/15

参照情報

CVE: CVE-2019-3811