DebianDLA-1781-1: qemuセキュリティ更新プログラム

critical Nessus プラグイン ID 124720

概要

リモートのDebianホストにセキュリティ更新プログラムがありません。

説明

高速プロセッサエミュレーターのQEMUに複数の脆弱性が見つかりました:

CVE-2018-11806

SLiRPネットワーキングの実装では、バッファを再割り当てするときに誤ったサイズを使用する可能性があります。ゲストの特権を持つユーザーがこれを悪用し、ホストシステムでサービス拒否、または任意コードの実行を引き起こす可能性があります。

CVE-2018-18849

LSI53C895A SCSI Host Bus Adapterエミュレーションは境界外メモリアクセスの影響を受けやすく、悪意のあるゲストユーザーがこれを利用してQEMUプロセスをクラッシュさせる可能性があります。

CVE-2018-20815

load_device_tree関数にヒープバッファオーバーフローが見つかりました。悪意のあるユーザーがこれを利用してQEMUプロセスの特権で任意コードを実行する可能性があります。

CVE-2019-9824

William Bowling氏が、SLiRPネットワークの実装では一部のメッセージが正しく処理されず、細工されたメッセージを介してメモリリークをトリガーする可能性があることを発見しました。

Debian 8「Jessie」では、これらの問題はバージョン1:2.1+dfsg-12+deb8u11で修正されました。

お使いのqemuパッケージをアップグレードすることを推奨します。

注: Tenable Network Securityは、前述の記述ブロックをDLAセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

影響を受けるパッケージをアップグレードしてください。

関連情報

https://lists.debian.org/debian-lts-announce/2019/05/msg00010.html

https://packages.debian.org/source/jessie/qemu

プラグインの詳細

深刻度: Critical

ID: 124720

ファイル名: debian_DLA-1781.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/5/10

更新日: 2021/1/11

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:qemu, p-cpe:/a:debian:debian_linux:qemu-guest-agent, p-cpe:/a:debian:debian_linux:qemu-kvm, p-cpe:/a:debian:debian_linux:qemu-system, p-cpe:/a:debian:debian_linux:qemu-system-arm, p-cpe:/a:debian:debian_linux:qemu-system-common, p-cpe:/a:debian:debian_linux:qemu-system-mips, p-cpe:/a:debian:debian_linux:qemu-system-misc, p-cpe:/a:debian:debian_linux:qemu-system-ppc, p-cpe:/a:debian:debian_linux:qemu-system-sparc, p-cpe:/a:debian:debian_linux:qemu-system-x86, p-cpe:/a:debian:debian_linux:qemu-user, p-cpe:/a:debian:debian_linux:qemu-user-binfmt, p-cpe:/a:debian:debian_linux:qemu-user-static, p-cpe:/a:debian:debian_linux:qemu-utils, cpe:/o:debian:debian_linux:8.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/5/9

脆弱性公開日: 2018/6/13

参照情報

CVE: CVE-2018-11806, CVE-2018-18849, CVE-2018-20815, CVE-2019-9824