CentOS 7:libvirt(CESA-2019:1177)(MDSUM/RIDL)(MFBDS/RIDL/ZombieLoad)(MLPDS/RIDL)(MSBDS/Fallout)

medium Nessus プラグイン ID 125169
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのCentOSホストに1つまたは複数のセキュリティ更新プログラムがありません。

説明

libvirtの更新プログラムが、Red Hat Enterprise Linux 7で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。libvirtライブラリには、Linuxなどのオペレーティングシステムの仮想化機能を管理、操作するためのC APIが含まれます。さらに、libvirtは、仮想化されたシステムをリモートで管理するためのツールも提供します。セキュリティ修正プログラム:* L1 CPUキャッシュでキャッシュミスが発生したときに最新のCPUで使用されるメカニズムである、「フィルバッファ」の実装に欠陥が見つかりました。攻撃者がページフォルトを発生させるロード操作を生成できる場合、データがより高いレベルのキャッシュからフェッチされている間、その実行はフィルバッファからの不適切なデータを使用して推測によって継続します。この応答時間を測定して、フィルバッファ内のデータを推測することができます。(CVE-2018-12130)* 最新のIntelマイクロプロセッサーは、データをCPUキャッシュに書き戻すパフォーマンスを向上させるために、ハードウェアレベルのマイクロ最適化を実装しています。書き込み操作は、STA(STore Address)とSTD(STore Data)のサブ操作に分けられます。これらのサブ操作により、プロセッサーはアドレス生成ロジックをこれらのサブオペレーションにハンドオフして書き込みを最適化できます。これらのサブ操作は両方とも、「プロセッサー格納バッファ」と呼ばれる共有分散プロセッサー構造に書き込みます。その結果、権限のない攻撃者がこの欠陥を悪用して、CPUのプロセッサー格納バッファ内にあるプライベートデータを読み取る可能性があります。(CVE-2018-12126)* マイクロプロセッサーは、「ロードポート」サブコンポーネントを使用して、メモリまたはIOからロード操作を実行します。ロード操作中、ロードポートはメモリまたはIOサブシステムからデータを受け取り、次にそのデータをCPUレジスタおよびCPUのパイプライン内の操作に提供します。古いロード操作の結果は、新しい操作で上書きされるまで「ロードポート」テーブルに格納されます。攻撃者は、攻撃者によってトリガーされた特定のロードポート操作を使用して以前の古いリクエストに関するデータを明らかにし、タイミングサイドチャネルを介してデータを漏えいさせる可能性があります。(CVE-2018-12127)投機的実行を利用する一部のマイクロプロセッサーのキャッシュ不可能なメモリにより、認証されたユーザーがローカルアクセスのサイドチャネルを介して情報を漏えいさせる可能性があります。(CVE-2019-11091)影響、CVSSスコア、謝辞、その他の関連情報を含むセキュリティ問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。

ソリューション

影響を受けるlibvirtパッケージを更新してください。

関連情報

http://www.nessus.org/u?151fab75

プラグインの詳細

深刻度: Medium

ID: 125169

ファイル名: centos_RHSA-2019-1177.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/5/16

更新日: 2020/1/17

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2019-11091

VPR

リスクファクター: High

スコア: 8.4

CVSS v2

リスクファクター: Medium

Base Score: 4.7

Temporal Score: 3.5

ベクトル: AV:L/AC:M/Au:N/C:C/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 5.6

Temporal Score: 4.9

ベクトル: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:libvirt, p-cpe:/a:centos:centos:libvirt-admin, p-cpe:/a:centos:centos:libvirt-bash-completion, p-cpe:/a:centos:centos:libvirt-client, p-cpe:/a:centos:centos:libvirt-daemon, p-cpe:/a:centos:centos:libvirt-daemon-config-network, p-cpe:/a:centos:centos:libvirt-daemon-config-nwfilter, p-cpe:/a:centos:centos:libvirt-daemon-driver-interface, p-cpe:/a:centos:centos:libvirt-daemon-driver-lxc, p-cpe:/a:centos:centos:libvirt-daemon-driver-network, p-cpe:/a:centos:centos:libvirt-daemon-driver-nodedev, p-cpe:/a:centos:centos:libvirt-daemon-driver-nwfilter, p-cpe:/a:centos:centos:libvirt-daemon-driver-qemu, p-cpe:/a:centos:centos:libvirt-daemon-driver-secret, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage-core, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage-disk, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage-gluster, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage-iscsi, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage-logical, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage-mpath, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage-rbd, p-cpe:/a:centos:centos:libvirt-daemon-driver-storage-scsi, p-cpe:/a:centos:centos:libvirt-daemon-kvm, p-cpe:/a:centos:centos:libvirt-daemon-lxc, p-cpe:/a:centos:centos:libvirt-devel, p-cpe:/a:centos:centos:libvirt-docs, p-cpe:/a:centos:centos:libvirt-libs, p-cpe:/a:centos:centos:libvirt-lock-sanlock, p-cpe:/a:centos:centos:libvirt-login-shell, p-cpe:/a:centos:centos:libvirt-nss, cpe:/o:centos:centos:7

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/5/15

脆弱性公開日: 2019/5/30

参照情報

CVE: CVE-2018-12126, CVE-2018-12127, CVE-2018-12130, CVE-2019-11091

RHSA: 2019:1177