CentOS 7:ruby(CESA-2019:1235)

high Nessus プラグイン ID 125316

概要

リモートのCentOSホストに1つまたは複数のセキュリティ更新プログラムがありません。

説明

Rubyの更新プログラムが、Red Hat Enterprise Linux 7で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度高と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。Rubyは、拡張可能なインタープリタ型の、オブジェクト指向スクリプト言語です。テキストファイルを処理する機能、およびシステム管理タスクを実行する機能があります。セキュリティ修正プログラム:* rubygems:悪意のあるgemをインストールすると、任意のコードが実行される可能性があります(CVE-2019-8324)* rubygems:gem所有者におけるエスケープシーケンスインジェクションの脆弱性(CVE-2019-8322)* rubygems:APIレスポンス処理におけるエスケープシーケンスインジェクションの脆弱性(CVE-2019-8323)* rubygems:エラーにおけるエスケープシーケンスインジェクションの脆弱性(CVE-2019-8325)影響、CVSSスコア、謝辞、その他の関連情報を含むセキュリティの問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。

ソリューション

影響を受けるRubyパッケージを更新してください。

関連情報

http://www.nessus.org/u?fd82bebc

プラグインの詳細

深刻度: High

ID: 125316

ファイル名: centos_RHSA-2019-1235.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2019/5/22

更新日: 2020/1/15

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2019-8324

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:ruby, p-cpe:/a:centos:centos:ruby-devel, p-cpe:/a:centos:centos:ruby-doc, p-cpe:/a:centos:centos:ruby-irb, p-cpe:/a:centos:centos:ruby-libs, p-cpe:/a:centos:centos:ruby-tcltk, p-cpe:/a:centos:centos:rubygem-bigdecimal, p-cpe:/a:centos:centos:rubygem-io-console, p-cpe:/a:centos:centos:rubygem-json, p-cpe:/a:centos:centos:rubygem-minitest, p-cpe:/a:centos:centos:rubygem-psych, p-cpe:/a:centos:centos:rubygem-rake, p-cpe:/a:centos:centos:rubygem-rdoc, p-cpe:/a:centos:centos:rubygems, p-cpe:/a:centos:centos:rubygems-devel, cpe:/o:centos:centos:7

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/5/21

脆弱性公開日: 2019/6/17

参照情報

CVE: CVE-2019-8322, CVE-2019-8323, CVE-2019-8324, CVE-2019-8325

RHSA: 2019:1235