DebianDLA-1812-1: doxygenのセキュリティ更新プログラム

medium Nessus プラグイン ID 125644
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのDebianホストにセキュリティ更新プログラムがありません。

説明

search_opensearch.php内のクエリパラメーターのサニタイズが不十分なために、折り返し型クロスサイトスクリプティングまたはiframeインジェクションが発生する可能性があります。

Debian 8「Jessie」では、この問題はバージョン1.8.8-5+deb8u1で修正されました。

お使いのdoxygenパッケージをアップグレードすることを推奨します。

注: Tenable Network Securityは、前述の記述ブロックをDLAセキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

影響を受けるパッケージをアップグレードしてください。

関連情報

https://lists.debian.org/debian-lts-announce/2019/05/msg00046.html

https://packages.debian.org/source/jessie/doxygen

プラグインの詳細

深刻度: Medium

ID: 125644

ファイル名: debian_DLA-1812.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/6/3

更新日: 2021/1/11

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:doxygen, p-cpe:/a:debian:debian_linux:doxygen-dbg, p-cpe:/a:debian:debian_linux:doxygen-doc, p-cpe:/a:debian:debian_linux:doxygen-gui, p-cpe:/a:debian:debian_linux:doxygen-latex, cpe:/o:debian:debian_linux:8.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/5/31

脆弱性公開日: 2019/5/24

参照情報

CVE: CVE-2016-10245