KB4507457:Windows 8.1およびWindows Server 2012 R2の2019年7月のセキュリティ更新プログラム

high Nessus プラグイン ID 126570
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのWindowsホストは、複数の脆弱性の影響を受けます。

説明

リモートのWindowsホストに、セキュリティ更新プログラム4507457または累積的な更新プログラム4507448がありません。したがって、複数の脆弱性の影響を受けます:- ソフトウェアがファイルのソースマークアップをチェックしないとき、リモートでコードが実行される脆弱性が.NETソフトウェアにあります。脆弱性の悪用に成功した攻撃者が、現在のユーザーのコンテキストで任意のコードを実行する可能性があります。現在のユーザーが管理者ユーザー権限でログオンしている場合、攻撃者が影響を受けるシステムを乗っ取る可能性があります。攻撃者が、完全なユーザー権限で、プログラムのインストール、データの表示・変更・削除、または新規アカウントの作成を実行する可能性があります。(CVE-2019-1113)- splwow64.exeが特定の呼び出しを処理する方法に、ローカルでの権限昇格の脆弱性があります。この脆弱性の悪用に成功した攻撃者が、影響を受けるシステムで、権限をLow整合性からMedium整合性に昇格させる可能性があります。この脆弱性だけでは、任意のコードが実行されることはありません。 ただし、攻撃者がコードの実行を試みるとき、昇格された権限を利用できる別の脆弱性(リモートでコードが実行される脆弱性または別の昇格権限の脆弱性など)と組み合わせて使用すると、任意のコードが実行される可能性があります。(CVE-2019-0880)- Windows RDPクライアントがメモリの内容を不適切に漏えいさせるとき、情報漏えいの脆弱性があります。この脆弱性を悪用した攻撃者が、ユーザーシステムをさらに侵害する情報を取得する可能性があります。(CVE-2019-1108)- win32kコンポーネントがカーネル情報を不適切に提供するとき、情報漏えいの脆弱性があります。この脆弱性を悪用した攻撃者が、ユーザーシステムをさらに侵害する情報を取得する可能性があります。(CVE-2019-1096)- ローカルサービス権限を持つ特定のdllがカスタマイズされたdllを配置する競合に対して脆弱であるため、Microsoft Windowsに権限昇格の脆弱性があります。この脆弱性の悪用に成功した攻撃者が、権限をSYSTEMに昇格させる可能性があります。この更新プログラムは特定のDLLに対してシステム権限を要求することで、この脆弱性に対応します。(CVE-2019-1082)- スクリプトエンジンがMicrosoftブラウザーのメモリ内のオブジェクトを処理する方法に、リモートでコードが実行される脆弱性があります。この脆弱性により、攻撃者が現在のユーザーのコンテキストで任意のコードを実行し、メモリを破損させる可能性があります。この脆弱性の悪用に成功した攻撃者は、現在のユーザーと同じユーザー権限を取得する可能性があります。(CVE-2019-1001)- Internet Explorerがメモリ内のオブジェクトに不適切にアクセスするとき、リモートでコードが実行される脆弱性があります。この脆弱性により、攻撃者が現在のユーザーのコンテキストで任意のコードを実行し、メモリを破損させる可能性があります。この脆弱性の悪用に成功した攻撃者は、現在のユーザーと同じユーザー権限を取得する可能性があります。(CVE-2019-1063)- Microsoftのブラウザーがメモリ内のオブジェクトにアクセスする方法に、リモートでコードが実行される脆弱性があります。この脆弱性により、攻撃者が現在のユーザーのコンテキストで任意のコードを実行し、メモリを破壊する可能性があります。この脆弱性の悪用に成功した攻撃者は、現在のユーザーと同じユーザー権限を取得する可能性があります。(CVE-2019-1104)- DirectWriteがそのメモリのコンテンツを不適切に漏えいするとき、情報漏えいの脆弱性があります。この脆弱性を悪用した攻撃者が、ユーザーシステムをさらに侵害する情報を取得する可能性があります。攻撃者がこの脆弱性を悪用する方法は複数あり、ユーザーを誘導して特別に細工されたドキュメントを開かせたり、信頼できないWebページにアクセスさせたりする可能性があります。このセキュリティ更新プログラムは、DirectWriteがメモリでオブジェクトを処理する方法を修正することで、この脆弱性に対応します。(CVE-2019-1093、CVE-2019-1097)- Windows GDIコンポーネントがメモリの内容を不適切に開示するとき、情報漏えいの脆弱性があります。この脆弱性を悪用した攻撃者が、ユーザーシステムをさらに侵害する情報を取得する可能性があります。攻撃者がこの脆弱性を悪用する方法は複数あり、ユーザーを誘導して特別に細工されたドキュメントを開かせたり、信頼できないWebページにアクセスさせたりする可能性があります。セキュリティ更新プログラムは、Windows GDIコンポーネントがメモリでオブジェクトを処理する方法を修正することにより、脆弱性に対応します。(CVE-2019-1094、CVE-2019-1095)- Windowsカーネルがメモリ内のオブジェクトを不適切に処理するとき、情報漏えいの脆弱性があります。この脆弱性を悪用した攻撃者が、ユーザーシステムをさらに侵害する情報を取得する可能性があります。認証された攻撃者は、特別に細工されたアプリケーションを実行し、この脆弱性を悪用する可能性があります。更新プログラムは、Windowsカーネルがメモリでオブジェクトを処理する方法を修正することで、この脆弱性に対応します。(CVE-2019-1071)- 権限昇格の脆弱性がWindows Audio Serviceにあります。脆弱性の悪用に成功した攻撃者は、昇格した権限で任意のコードを実行する可能性があります。(CVE-2019-1086、CVE-2019-1087、CVE-2019-1088)- Windows AppX Deployment Service(AppXSVC)がハードリンクを不適切に処理するとき、権限昇格の脆弱性があります。この脆弱性を悪用した攻撃者は、昇格したコンテキストでプロセスを実行する可能性があります。攻撃者がプログラムをインストール、データを表示、変更、削除する可能性があります。(CVE-2019-1130)- スクリプトエンジンがInternet Explorerのメモリ内のオブジェクトを処理する方法に、リモートでコードが実行される脆弱性があります。この脆弱性により、攻撃者が現在のユーザーのコンテキストで任意のコードを実行し、メモリを破損させる可能性があります。この脆弱性の悪用に成功した攻撃者は、現在のユーザーと同じユーザー権限を取得する可能性があります。(CVE-2019-1004、CVE-2019-1056、CVE-2019-1059)- Active Directory Federation Services(ADFS)にセキュリティ機能をバイパスされる脆弱性があるため、攻撃者がエクストラネットのロックアウトポリシーをバイパスする可能性があります。(CVE-2019-1126)- 認証された攻撃者がクリップボードのリダイレクトを悪用したとき、以前はターミナルサービスと呼ばれていたリモートデスクトップサービスにリモートでコードが実行される脆弱性があります。この脆弱性の悪用に成功した攻撃者が、被害者のシステムで任意のコードを実行する可能性があります。攻撃者が、完全なユーザー権限で、プログラムのインストール、データの表示・変更・削除、または新規アカウントの作成を実行する可能性があります。(CVE-2019-0887)- wlansvc.dllがメモリ内のオブジェクトを処理する方法に権限昇格の脆弱性があります。脆弱性の悪用に成功した攻撃者が、昇格したアクセス許可でコードを実行する可能性があります。(CVE-2019-1085)- Microsoft Common Objectランタイムライブラリが不適切にWebリクエストを処理するとき、サービス拒否の脆弱性があります。この脆弱性の悪用に成功した攻撃者は、.NET Webアプリケーションに対するサービス拒否を引き起こす可能性があります。リモートの認証されていない攻撃者がこの脆弱性を悪用し、特別に細工されたリクエストを.NETアプリケーションに発行する可能性があります。この更新プログラムでは、.NET WebアプリケーションがWebリクエストを処理する方法が修正され、この脆弱性に対処しています。(CVE-2019-1083)- 攻撃者が特別に細工されたパケットをDHCPフェールオーバーサーバーに送信するとき、Windows Server DHCPサービスにメモリ破損の脆弱性があります。この脆弱性の悪用に成功した攻撃者が、DHCPフェールオーバーサーバーで任意のコードを実行したり、DHCPサービスの応答を停止させたりする可能性があります。(CVE-2019-0785)- RPCサービスのActivation KernelがRPCリクエストを正しく処理しないとき、rpcss.dllに権限昇格の脆弱性があります。(CVE-2019-1089)- Windowsカーネルがメモリ内のオブジェクトを不適切に処理するとき、情報漏えいの脆弱性があります。この脆弱性を悪用した攻撃者が、ユーザーシステムをさらに侵害する情報を取得する可能性があります。(CVE-2019-1073)- リモートでコードが実行される脆弱性が、Windowsグラフィックデバイスインターフェイス(GDI)がメモリでオブジェクトを処理する方法にあります。この脆弱性の悪用に成功した攻撃者が、影響を受けるシステムを乗っ取る可能性があります。攻撃者が、完全なユーザー権限で、プログラムのインストール、データの表示・変更・削除、または新規アカウントの作成を実行する可能性があります。(CVE-2019-1102)- Windows Communication Foundation(WCF)およびWindows Identity Foundation(WIF)に認証バイパスの脆弱性があるため、任意の対称鍵を使ってSAMLトークンに署名される可能性があります。この脆弱性により、攻撃者が他のユーザーになりすまして、権限を昇格させる可能性があります。この脆弱性は、.NET FrameworkのWCFとWIF 3.5以降、WindowsのWIF 1.0コンポーネント、WIF Nugetパッケージ、SharePointのWIF実装にあります。認証されていない攻撃者がこれを悪用して、任意の対称鍵を使用してSAMLトークンに署名する可能性があります。このセキュリティ更新プログラムは、WCFおよびWIFのすべてのバージョンがSAMLトークンに正しく署名するために使用されるキーを検証するようにすることで、この脆弱性に対応します。(CVE-2019-1006)- WindowsのDNSサーバーがDNSクエリを正しく処理しないとき、WindowsのDNSサーバーにサービス拒否の脆弱性があります。この脆弱性の悪用に成功した攻撃者が、DNSサーバーサービスの応答を停止させる可能性があります。(CVE-2019-0811)

ソリューション

セキュリティのみの更新プログラムKB4507457、または累積的な更新プログラムKB4507448を適用します。

関連情報

http://www.nessus.org/u?d231fad3

http://www.nessus.org/u?1d422a75

プラグインの詳細

深刻度: High

ID: 126570

ファイル名: smb_nt_ms19_jul_4507448.nasl

バージョン: 1.8

タイプ: local

エージェント: windows

公開日: 2019/7/9

更新日: 2021/2/5

依存関係: smb_check_rollup.nasl, smb_hotfixes.nasl, ms_bulletin_checks_possible.nasl

リスク情報

CVSS スコアのソース: CVE-2019-1102

VPR

リスクファクター: Critical

スコア: 9.7

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 8.1

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 8.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:microsoft:windows

必要な KB アイテム: SMB/MS_Bulletin_Checks/Possible

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/7/9

脆弱性公開日: 2019/7/9

参照情報

CVE: CVE-2019-0785, CVE-2019-0811, CVE-2019-0880, CVE-2019-0887, CVE-2019-1001, CVE-2019-1004, CVE-2019-1006, CVE-2019-1056, CVE-2019-1059, CVE-2019-1063, CVE-2019-1071, CVE-2019-1073, CVE-2019-1082, CVE-2019-1083, CVE-2019-1085, CVE-2019-1086, CVE-2019-1087, CVE-2019-1088, CVE-2019-1089, CVE-2019-1093, CVE-2019-1094, CVE-2019-1095, CVE-2019-1096, CVE-2019-1097, CVE-2019-1102, CVE-2019-1104, CVE-2019-1108, CVE-2019-1113, CVE-2019-1125, CVE-2019-1126, CVE-2019-1130

MSKB: 4507448, 4507457

MSFT: MS19-4507448, MS19-4507457