CentOS 7:libtiff(CESA-2019:2053)

high Nessus プラグイン ID 128343
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのCentOSホストに1つ以上のセキュリティ更新プログラムがありません。

説明

libtiffの更新プログラムが、Red Hat Enterprise Linux 7で利用可能になりました。Red Hat製品セキュリティは、この更新がセキュリティに及ぼす影響を重要度中と評価しています。詳細な重要度評価を示すCVSS(共通脆弱性評価システム)ベーススコアは、「参照」セクションのCVEリンクから脆弱性ごとに入手できます。libtiffパッケージには、TIFF(Tagged Image File Format)ファイルを操作するための関数のライブラリが含まれます。セキュリティ修正プログラム:* libtiff:gif2tiffのバッファオーバーフロー(CVE-2016-3186)* libtiff:cpSeparateBufToContigBuf関数のヒープベースのバッファオーバーフローにより、サービス拒否の発生またはコード実行の可能性(CVE-2018-12900)* libtiff:tif_jbig.cの領域外書き込み(CVE-2018-18557)* libtiff:tif_print.c:TIFFPrintDirectory()のNULLポインターデリファレンスにより、サービス拒否が発生(CVE-2018-7456)* libtiff:tif_lzw.c:LZWDecodeCompat()のヒープベースのバッファオーバーフローにより、サービス拒否の可能性(CVE-2018-8905)* libtiff:tif_write.cのTIFFWriteScanline関数におけるヒープベースのバッファオーバーリード(CVE-2018-10779)* libtiff:tif_dirwrite.cのTIFFWriteDirectorySec関数における到達可能なアサーション(CVE-2018-10963)* libtiff:tools/ppm2tiff.cのmultiply_msにおける整数オーバーフロー(CVE-2018-17100)* libtiff:tools/tiff2bw.cおよびtools/pal2rgb.cのcpTagsにおける2つの領域外書き込み(CVE-2018-17101)* libtiff:tiff2bwツールのメモリ割り当てに失敗によるクラッシュ(CVE-2018-18661)影響、CVSSスコア、謝辞、その他の関連情報を含むセキュリティ問題の詳細については、「参照」セクションに記載されているCVEのページを参照してください。追加の変更:このリリースの変更に関する詳細については、「参照」セクションにリンクされているRed Hat Enterprise Linux 7.7リリースノートを参照してください。

ソリューション

影響を受けるlibtiffパッケージを更新してください。

関連情報

http://www.nessus.org/u?fe9837da

プラグインの詳細

深刻度: High

ID: 128343

ファイル名: centos_RHSA-2019-2053.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2019/8/30

更新日: 2019/12/31

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2018-12900

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:centos:centos:libtiff, p-cpe:/a:centos:centos:libtiff-devel, p-cpe:/a:centos:centos:libtiff-static, p-cpe:/a:centos:centos:libtiff-tools, cpe:/o:centos:centos:7

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/8/29

脆弱性公開日: 2016/4/19

参照情報

CVE: CVE-2016-3186, CVE-2018-10779, CVE-2018-10963, CVE-2018-12900, CVE-2018-17100, CVE-2018-17101, CVE-2018-18557, CVE-2018-18661, CVE-2018-7456, CVE-2018-8905

RHSA: 2019:2053