openSUSEセキュリティ更新プログラム:ghostscript(openSUSE-2019-2223)

critical Nessus プラグイン ID 129483

言語:

概要

リモートのopenSUSEホストに、セキュリティ更新プログラムがありません。

説明

このghostscript用の更新プログラムでは、次の問題を修正します:

キャッシュサイドチャネル攻撃の軽減:

- CVE-2019-3835:利用可能なsuperexec演算子により引き起こされる不正なファイルシステムアクセスを修正しました。(bsc#1129180)

- CVE-2019-3839:利用可能なprivileged演算子により引き起こされる不正なファイルシステムアクセスを修正しました。(bsc#1134156)

- CVE-2019-12973:OpenJPEG関数opj_t1_encode_cblksでのサービス拒否の脆弱性を修正しました。
(bsc#1140359)

- CVE-2019-14811:.pdf_hook_DSC_Creatorの.forceputエクスポージャーによる、より安全なモードのバイパスを修正しました。(bsc#1146882)

- CVE-2019-14812:setuserparamsの.forceputエクスポージャーによる、より安全なモードのバイパスを修正しました。(bsc#1146882)

- CVE-2019-14813:setsystemparamsの.forceputエクスポージャーによる、より安全なモードのバイパスを修正しました。(bsc#1146882)

- CVE-2019-14817:.pdfexectokenおよびその他のプロシージャーの.forceputエクスポージャーによるより安全なモードのバイパスを修正しました。
(bsc#1146884)

この更新はSUSEからインポートされました:SLE-15:更新プロジェクトを更新します。

ソリューション

影響を受けるghostscriptパッケージを更新してください。

関連情報

https://bugzilla.opensuse.org/show_bug.cgi?id=1129180

https://bugzilla.opensuse.org/show_bug.cgi?id=1129186

https://bugzilla.opensuse.org/show_bug.cgi?id=1134156

https://bugzilla.opensuse.org/show_bug.cgi?id=1140359

https://bugzilla.opensuse.org/show_bug.cgi?id=1146882

https://bugzilla.opensuse.org/show_bug.cgi?id=1146884

プラグインの詳細

深刻度: Critical

ID: 129483

ファイル名: openSUSE-2019-2223.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2019/10/1

更新日: 2021/7/6

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 8.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:ghostscript, p-cpe:/a:novell:opensuse:ghostscript-debuginfo, p-cpe:/a:novell:opensuse:ghostscript-debugsource, p-cpe:/a:novell:opensuse:ghostscript-devel, p-cpe:/a:novell:opensuse:ghostscript-mini, p-cpe:/a:novell:opensuse:ghostscript-mini-debuginfo, p-cpe:/a:novell:opensuse:ghostscript-mini-debugsource, p-cpe:/a:novell:opensuse:ghostscript-mini-devel, p-cpe:/a:novell:opensuse:ghostscript-x11, p-cpe:/a:novell:opensuse:ghostscript-x11-debuginfo, cpe:/o:novell:opensuse:15.1

必要な KB アイテム: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/9/30

脆弱性公開日: 2019/3/25

参照情報

CVE: CVE-2019-12973, CVE-2019-14811, CVE-2019-14812, CVE-2019-14813, CVE-2019-14817, CVE-2019-3835, CVE-2019-3839

IAVB: 2019-B-0081-S