JQuery 1.2 < 3.5.0 複数のXSS

medium Nessus プラグイン ID 136929
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

The remote web server is affected by multiple cross site scripting vulnerability.

説明

スクリプトで自己報告されたバージョンによると、リモートWebサーバーでホストされているJQueryのバージョンは1.2以降3.5.0より前です。したがって、複数のクロスサイトスクリプティングの脆弱性の影響を受けます。

注意: このプラグインで参照されている脆弱性は、PAN-OSに対するセキュリティの影響はなく、悪用に成功するために必要なシナリオはPAN-OSリリースを実行しているデバイスには存在しません。

ソリューション

Upgrade to JQuery version 3.5.0 or later.

関連情報

https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/

https://security.paloaltonetworks.com/PAN-SA-2020-0007

プラグインの詳細

深刻度: Medium

ID: 136929

ファイル名: jquery_cve-2020-11022.nasl

バージョン: 1.9

タイプ: remote

ファミリー: CGI abuses : XSS

公開日: 2020/5/28

更新日: 2021/4/15

依存関係: jquery_detect.nasl, palo_alto_version.nbin, cisco_wlc_version.nasl

リスク情報

CVSS スコアのソース: CVE-2020-11022

VPR

リスクファクター: Medium

スコア: 4.6

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.4

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

必要な KB アイテム: installed_sw/jquery

除外される KB アイテム: Host/Palo_Alto/Firewall/Version, Host/Cisco/WLC/Version

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2020/4/10

脆弱性公開日: 2020/4/29

参照情報

CVE: CVE-2020-11022, CVE-2020-11023

IAVB: 2020-B-0030