SUSE SLES12セキュリティ更新プログラム:カーネル(SUSE-SU-2020:2119-1)

critical Nessus プラグイン ID 139361

言語:

概要

リモートのSUSEホストに1つ以上のセキュリティ更新がありません。

説明

SUSE Linux Enterprise 12 SP5カーネルが更新され、さまざまなセキュリティとバグの修正が行われています。

以下のセキュリティバグが修正されました。

CVE-2020-15780:ACPIテーブルのインジェクションを使用して未署名モジュールをロードするためのロックダウンバイパスが修正されました。(bsc#1173573)

CVE-2020-15393:usbtest_disconnectでのメモリリークを修正しました(bnc#1173514)。

CVE-2020-12771:drivers/md/bcache/btree.c内のbtree_gc_coalesceで、一体化操作が失敗した場合にデッドロックが発生する問題が検出されました(bnc#1171732)。

CVE-2020-12888:VFIO PCIドライバーは、無効なメモリ空間へのアクセスの試行を誤って処理します(bnc#1171868)。

CVE-2020-10773:arch/s390/mm/cmm.cファイルのcmm_timeout_hander内のs390/s390xにおけるメモリリークを修正しました(bnc#1172999)。

CVE-2020-14416:slipおよびslcan回線制御のtty->disc_data処理における競合状態によって、Use-After-Freeが引き起こされる可能性がある問題を修正しました。
これはdrivers/net/slip/slip.cおよびdrivers/net/can/slcan.cに影響します(bnc#1162002)。

CVE-2020-0305:char_dev.cのcdev_getにおける競合状態によってUse-After-Freeが発生する可能性がある問題を修正しました。これはローカルの権限昇格を引き起こす可能性があります。悪用はユーザーの操作を必要としません(bnc#1174462)。

CVE-2020-10769:IPsec暗号化アルゴリズムのモジュールであるauthencのcrypto/authenc.cのcrypto_authenc_extractkeysで、バッファオーバーリードの欠陥が見つかりました。この欠陥により、ユーザー権限を持つローカルの攻撃者がサービス拒否を引き起こす可能性があります(bnc#1173265)。

CVE-2020-10781:ZRAM実装におけるサービス拒否の問題を修正しました(bnc#1173074)。

CVE-2019-20908:efivar_ssdt ACPI変数に対する誤ったアクセス権限を修正しました。攻撃者はこれを使用して、ロックダウンまたはセキュアブート制限をバイパスすることができます(bnc#1173567)。

CVE-2019-16746:ビーコンヘッド内の変数要素の無効な長さチェックに関連する、net/wireless/nl80211.cでのバッファオーバーフローを修正しました(bnc#1152107)。

CVE-2020-10135:Bluetoothのレガシーペアリングおよび安全な接続のペア認証では、認証されていないユーザーが隣接アクセスを介して認証情報をペアリングせずに認証を完了する可能性がありました。認証されていない近接の攻撃者がBluetooth BR/EDRマスターまたはスレーブになりすまして、以前にペアリングしたリモートデバイスとペアリングさせ、リンクキーを知らなくても認証手順を正常に完了する可能性があります(bnc#1171988)。

CVE-2020-14331:vgacon_scrollback_update()でのバッファオーバーライトを修正しました(bnc#1174205)。

更新パッケージには、セキュリティ関連以外の修正も含まれています。詳細については、アドバイザリを参照してください。

注意:Tenable Network Securityは、前述の記述ブロックをSUSEセキュリティアドバイザリから直接抽出しています。Tenableでは、そこに新しい問題を追加することはせずに、できる限り自動的に整理と書式設定をするようにしています。

ソリューション

このSUSEセキュリティ更新プログラムをインストールするには、YaSTのonline_updateや「zypper patch」など、SUSEが推奨するインストール方法を使用してください。

別の方法として、製品にリストされているコマンドを実行することができます:

SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-2119=1

関連情報

https://bugzilla.suse.com/show_bug.cgi?id=1051510

https://bugzilla.suse.com/show_bug.cgi?id=1065729

https://bugzilla.suse.com/show_bug.cgi?id=1104967

https://bugzilla.suse.com/show_bug.cgi?id=1111666

https://bugzilla.suse.com/show_bug.cgi?id=1112178

https://bugzilla.suse.com/show_bug.cgi?id=1113956

https://bugzilla.suse.com/show_bug.cgi?id=1114279

https://bugzilla.suse.com/show_bug.cgi?id=1150660

https://bugzilla.suse.com/show_bug.cgi?id=1151927

https://bugzilla.suse.com/show_bug.cgi?id=1152107

https://bugzilla.suse.com/show_bug.cgi?id=1152624

https://bugzilla.suse.com/show_bug.cgi?id=1158983

https://bugzilla.suse.com/show_bug.cgi?id=1159058

https://bugzilla.suse.com/show_bug.cgi?id=1162002

https://bugzilla.suse.com/show_bug.cgi?id=1163309

https://bugzilla.suse.com/show_bug.cgi?id=1167104

https://bugzilla.suse.com/show_bug.cgi?id=1168959

https://bugzilla.suse.com/show_bug.cgi?id=1169514

https://bugzilla.suse.com/show_bug.cgi?id=1169771

https://bugzilla.suse.com/show_bug.cgi?id=1169795

https://bugzilla.suse.com/show_bug.cgi?id=1170011

https://bugzilla.suse.com/show_bug.cgi?id=1170442

https://bugzilla.suse.com/show_bug.cgi?id=1170617

https://bugzilla.suse.com/show_bug.cgi?id=1170618

https://bugzilla.suse.com/show_bug.cgi?id=1171124

https://bugzilla.suse.com/show_bug.cgi?id=1171424

https://bugzilla.suse.com/show_bug.cgi?id=1171529

https://bugzilla.suse.com/show_bug.cgi?id=1171530

https://bugzilla.suse.com/show_bug.cgi?id=1171558

https://bugzilla.suse.com/show_bug.cgi?id=1171673

https://bugzilla.suse.com/show_bug.cgi?id=1171732

https://bugzilla.suse.com/show_bug.cgi?id=1171739

https://bugzilla.suse.com/show_bug.cgi?id=1171743

https://bugzilla.suse.com/show_bug.cgi?id=1171753

https://bugzilla.suse.com/show_bug.cgi?id=1171759

https://bugzilla.suse.com/show_bug.cgi?id=1171761

https://bugzilla.suse.com/show_bug.cgi?id=1171835

https://bugzilla.suse.com/show_bug.cgi?id=1171841

https://bugzilla.suse.com/show_bug.cgi?id=1171868

https://bugzilla.suse.com/show_bug.cgi?id=1171988

https://bugzilla.suse.com/show_bug.cgi?id=1172247

https://bugzilla.suse.com/show_bug.cgi?id=1172257

https://bugzilla.suse.com/show_bug.cgi?id=1172344

https://bugzilla.suse.com/show_bug.cgi?id=1172484

https://bugzilla.suse.com/show_bug.cgi?id=1172687

https://bugzilla.suse.com/show_bug.cgi?id=1172719

https://bugzilla.suse.com/show_bug.cgi?id=1172871

https://bugzilla.suse.com/show_bug.cgi?id=1172872

https://bugzilla.suse.com/show_bug.cgi?id=1172999

https://bugzilla.suse.com/show_bug.cgi?id=1173060

https://bugzilla.suse.com/show_bug.cgi?id=1173074

https://bugzilla.suse.com/show_bug.cgi?id=1173146

https://bugzilla.suse.com/show_bug.cgi?id=1173265

https://bugzilla.suse.com/show_bug.cgi?id=1173280

https://bugzilla.suse.com/show_bug.cgi?id=1173284

https://bugzilla.suse.com/show_bug.cgi?id=1173428

https://bugzilla.suse.com/show_bug.cgi?id=1173462

https://bugzilla.suse.com/show_bug.cgi?id=1173514

https://bugzilla.suse.com/show_bug.cgi?id=1173567

https://bugzilla.suse.com/show_bug.cgi?id=1173573

https://bugzilla.suse.com/show_bug.cgi?id=1173659

https://bugzilla.suse.com/show_bug.cgi?id=1173746

https://bugzilla.suse.com/show_bug.cgi?id=1173818

https://bugzilla.suse.com/show_bug.cgi?id=1173820

https://bugzilla.suse.com/show_bug.cgi?id=1173825

https://bugzilla.suse.com/show_bug.cgi?id=1173826

https://bugzilla.suse.com/show_bug.cgi?id=1173833

https://bugzilla.suse.com/show_bug.cgi?id=1173838

https://bugzilla.suse.com/show_bug.cgi?id=1173839

https://bugzilla.suse.com/show_bug.cgi?id=1173845

https://bugzilla.suse.com/show_bug.cgi?id=1173857

https://bugzilla.suse.com/show_bug.cgi?id=1174113

https://bugzilla.suse.com/show_bug.cgi?id=1174115

https://bugzilla.suse.com/show_bug.cgi?id=1174122

https://bugzilla.suse.com/show_bug.cgi?id=1174123

https://bugzilla.suse.com/show_bug.cgi?id=1174130

https://bugzilla.suse.com/show_bug.cgi?id=1174186

https://bugzilla.suse.com/show_bug.cgi?id=1174187

https://bugzilla.suse.com/show_bug.cgi?id=1174205

https://bugzilla.suse.com/show_bug.cgi?id=1174247

https://bugzilla.suse.com/show_bug.cgi?id=1174296

https://bugzilla.suse.com/show_bug.cgi?id=1174343

https://bugzilla.suse.com/show_bug.cgi?id=1174356

https://bugzilla.suse.com/show_bug.cgi?id=1174409

https://bugzilla.suse.com/show_bug.cgi?id=1174438

https://bugzilla.suse.com/show_bug.cgi?id=1174462

https://bugzilla.suse.com/show_bug.cgi?id=1174543

https://bugzilla.suse.com/show_bug.cgi?id=1174549

https://www.suse.com/security/cve/CVE-2019-16746/

https://www.suse.com/security/cve/CVE-2019-20908/

https://www.suse.com/security/cve/CVE-2020-0305/

https://www.suse.com/security/cve/CVE-2020-10135/

https://www.suse.com/security/cve/CVE-2020-10769/

https://www.suse.com/security/cve/CVE-2020-10773/

https://www.suse.com/security/cve/CVE-2020-10781/

https://www.suse.com/security/cve/CVE-2020-12771/

https://www.suse.com/security/cve/CVE-2020-12888/

https://www.suse.com/security/cve/CVE-2020-14331/

https://www.suse.com/security/cve/CVE-2020-14416/

https://www.suse.com/security/cve/CVE-2020-15393/

https://www.suse.com/security/cve/CVE-2020-15780/

http://www.nessus.org/u?2d509505

プラグインの詳細

深刻度: Critical

ID: 139361

ファイル名: suse_SU-2020-2119-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2020/8/6

更新日: 2020/8/13

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:kernel-azure, p-cpe:/a:novell:suse_linux:kernel-azure-base, p-cpe:/a:novell:suse_linux:kernel-azure-base-debuginfo, p-cpe:/a:novell:suse_linux:kernel-azure-debuginfo, p-cpe:/a:novell:suse_linux:kernel-azure-debugsource, p-cpe:/a:novell:suse_linux:kernel-azure-devel, p-cpe:/a:novell:suse_linux:kernel-syms-azure, cpe:/o:novell:suse_linux:12

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2020/8/4

脆弱性公開日: 2019/9/24

参照情報

CVE: CVE-2019-16746, CVE-2019-20908, CVE-2020-0305, CVE-2020-10135, CVE-2020-10769, CVE-2020-10773, CVE-2020-10781, CVE-2020-12771, CVE-2020-12888, CVE-2020-14331, CVE-2020-14416, CVE-2020-15393, CVE-2020-15780