Debian DLA-2333-1: imagemagickセキュリティ更新

critical Nessus プラグイン ID 139675
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートの Debian ホストにセキュリティ更新プログラムがありません。

説明

Imagemagickで複数のセキュリティ脆弱性が修正されました。不正な形式の画像ファイルが処理される場合、さまざまなメモリ処理の問題があり、入力サニタイズが欠如しているか不完全であるならば、サービス拒否、メモリまたはCPUの消費、または任意コードの実行が発生する可能性があります。

Debian 9「Stretch」では、これらの問題はバージョン8:6.9.7.4+dfsg-11+deb9u9で修正されています。

お使いの imagemagick パッケージをアップグレードすることを推奨します。

imagemagick の詳細なセキュリティステータスについては、そのセキュリティトラッカーページを参照してください:
https://security-tracker.debian.org/tracker/imagemagick

注: Tenable Network Securityは、前述の記述ブロックを DLA セキュリティアドバイザリから直接抽出しています。Tenableでは、新たな問題を持ち込まずに、できる限り自動的に整理して書式設定するようにしています。

ソリューション

影響を受けるパッケージをアップグレードしてください。

関連情報

https://lists.debian.org/debian-lts-announce/2020/08/msg00030.html

https://packages.debian.org/source/stretch/imagemagick

https://security-tracker.debian.org/tracker/source-package/imagemagick

プラグインの詳細

深刻度: Critical

ID: 139675

ファイル名: debian_DLA-2333.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2020/8/19

更新日: 2020/8/21

依存関係: ssh_get_info.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:imagemagick, p-cpe:/a:debian:debian_linux:imagemagick-6-common, p-cpe:/a:debian:debian_linux:imagemagick-6-doc, p-cpe:/a:debian:debian_linux:imagemagick-6.q16, p-cpe:/a:debian:debian_linux:imagemagick-6.q16hdri, p-cpe:/a:debian:debian_linux:imagemagick-common, p-cpe:/a:debian:debian_linux:imagemagick-doc, p-cpe:/a:debian:debian_linux:libimage-magick-perl, p-cpe:/a:debian:debian_linux:libimage-magick-q16-perl, p-cpe:/a:debian:debian_linux:libimage-magick-q16hdri-perl, p-cpe:/a:debian:debian_linux:libmagick%2b%2b-6-headers, p-cpe:/a:debian:debian_linux:libmagick%2b%2b-6.q16-7, p-cpe:/a:debian:debian_linux:libmagick%2b%2b-6.q16-dev, p-cpe:/a:debian:debian_linux:libmagick%2b%2b-6.q16hdri-7, p-cpe:/a:debian:debian_linux:libmagick%2b%2b-6.q16hdri-dev, p-cpe:/a:debian:debian_linux:libmagick%2b%2b-dev, p-cpe:/a:debian:debian_linux:libmagickcore-6-arch-config, p-cpe:/a:debian:debian_linux:libmagickcore-6-headers, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16-3, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16-3-extra, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16-dev, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16hdri-3, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16hdri-3-extra, p-cpe:/a:debian:debian_linux:libmagickcore-6.q16hdri-dev, p-cpe:/a:debian:debian_linux:libmagickcore-dev, p-cpe:/a:debian:debian_linux:libmagickwand-6-headers, p-cpe:/a:debian:debian_linux:libmagickwand-6.q16-3, p-cpe:/a:debian:debian_linux:libmagickwand-6.q16-dev, p-cpe:/a:debian:debian_linux:libmagickwand-6.q16hdri-3, p-cpe:/a:debian:debian_linux:libmagickwand-6.q16hdri-dev, p-cpe:/a:debian:debian_linux:libmagickwand-dev, p-cpe:/a:debian:debian_linux:perlmagick, cpe:/o:debian:debian_linux:9.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2020/8/18

脆弱性公開日: 2017/12/14

参照情報

CVE: CVE-2017-12805, CVE-2017-17681, CVE-2017-18252, CVE-2018-10177, CVE-2018-14551, CVE-2018-18024, CVE-2018-20467, CVE-2018-7443, CVE-2018-8804, CVE-2018-8960, CVE-2018-9133, CVE-2019-10131, CVE-2019-11470, CVE-2019-11472, CVE-2019-11597, CVE-2019-12974, CVE-2019-12977, CVE-2019-12978, CVE-2019-12979, CVE-2019-13295, CVE-2019-13297, CVE-2019-13454, CVE-2019-14981, CVE-2019-19949