OpenWrt < 18.06.2 XSS(直接チェック)

medium Nessus プラグイン ID 143480

概要

リモートWebサーバーで起動されているwebアプリケーションは、クロスサイトスクリプティング脆弱性の影響を受けます。

説明

ユーザー指定の入力がユーザーに返す前に不適切に検証されているため、クロスサイトスクリプティング(XSS)の脆弱性がOpenWrt webユーザーインターフェースにあります。認証されていないリモートの攻撃者がこれを悪用し、特別に細工されたURLをクリックするようユーザーを誘導して、ユーザーのブラウザセッションで任意のスクリプトコードを実行する可能性があります。

ソリューション

OpenWrtバージョン18.06.2以降にアップグレードしてください

関連情報

https://bugs.openwrt.org/index.php?do=details&task_id=1974

プラグインの詳細

深刻度: Medium

ID: 143480

ファイル名: openwrt_cve_2018_19630.nbin

バージョン: 1.16

タイプ: remote

ファミリー: CGI abuses : XSS

公開日: 2020/12/4

更新日: 2022/5/24

リスク情報

CVSS スコアのソース: CVE-2018-19630

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.3

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:openwrt:openwrt

必要な KB アイテム: Host/OS/OpenWrt

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2018/11/28

脆弱性公開日: 2018/11/28

参照情報

CVE: CVE-2018-19630