CentOS 8:grub2(CESA-2021:0696)

high Nessus プラグイン ID 146965
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのCentOSホストに1つ以上のセキュリティ更新プログラムが欠落しています。

説明

リモートのCentOS Linux 8ホストにインストールされているパッケージは、CESA-2021: 0696のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- grub2:acpiコマンドにより権限のあるユーザーが、セキュアブートが有効な場合に、細工されたACPIテーブルをロードすることができます(CVE-2020-14372)

- grub2:rmmodコマンドでのUse-After-Free(CVE-2020-25632)

- grub2:grub_usb_device_initialize()での領域外書き込み(CVE-2020-25647)

- grub2:grub_parser_split_cmdline()でのバッファオーバーフローのスタック(CVE-2020-27749)

- grub2:cutmemコマンドにより、セキュアブートが有効な場合に、権限のあるユーザーがメモリ領域を削除することができます(CVE-2020-27779)

- grub2:ショートフォームオプションパーサーでのヒープ領域外書き込み(CVE-2021-20225)

- grub2:引用に必要なスペースの計算間違いによるヒープ領域外書き込み(CVE-2021-20233)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2021:0696

プラグインの詳細

深刻度: High

ID: 146965

ファイル名: centos8_RHSA-2021-0696.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2021/3/3

更新日: 2021/3/23

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2021-20233

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: High

Base Score: 8.2

Temporal Score: 7.1

ベクトル: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:centos:centos:8, cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:grub2-common, p-cpe:/a:centos:centos:grub2-efi-aa64, p-cpe:/a:centos:centos:grub2-efi-aa64-cdboot, p-cpe:/a:centos:centos:grub2-efi-aa64-modules, p-cpe:/a:centos:centos:grub2-efi-ia32, p-cpe:/a:centos:centos:grub2-efi-ia32-cdboot, p-cpe:/a:centos:centos:grub2-efi-ia32-modules, p-cpe:/a:centos:centos:grub2-efi-x64, p-cpe:/a:centos:centos:grub2-efi-x64-cdboot, p-cpe:/a:centos:centos:grub2-efi-x64-modules, p-cpe:/a:centos:centos:grub2-pc, p-cpe:/a:centos:centos:grub2-pc-modules, p-cpe:/a:centos:centos:grub2-ppc64le, p-cpe:/a:centos:centos:grub2-ppc64le-modules, p-cpe:/a:centos:centos:grub2-tools, p-cpe:/a:centos:centos:grub2-tools-efi, p-cpe:/a:centos:centos:grub2-tools-extra, p-cpe:/a:centos:centos:grub2-tools-minimal

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/3/2

脆弱性公開日: 2021/3/2

参照情報

CVE: CVE-2020-14372, CVE-2020-25632, CVE-2020-25647, CVE-2020-27749, CVE-2020-27779, CVE-2021-20225, CVE-2021-20233

RHSA: 2021:0696