CentOS 8:virt: rhelおよびvirt-devel: rhel(CESA-2021:1762)

medium Nessus プラグイン ID 149772
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートのCentOSホストに1つ以上のセキュリティ更新プログラムが欠落しています。

説明

リモートのCentOS Linux 8ホストにインストールされているパッケージには、CESA-2021:1762アドバイザリに記載された複数の脆弱性の影響を受けます。

- QEMU:block / iscsi.cのiscsi_aio_ioctl_cb()のヒープバッファオーバーフローにより、情報漏洩が発生する可能性があります(CVE-2020-11947)

- QEMU:hw/net/net_tx_pkt.c の net_tx_pkt_add_raw_fragment()での到達可能なアサーション失敗(CVE-2020-16092)

- libvirt: qemu_agent.cのqemuAgentGetInterfaces()における二重の自由(CVE-2020-25637)

- QEMU:hw/net/e1000e_core.cのe1000e_write_packet_to_guest()の無限ループ(CVE-2020-25707)

- QEMU:hw / usb / hcd-ehci.cのusb_packet_unmap()を通じたアサーションの失敗(CVE-2020-25723)

- QEMU:hw/pci/msix.cのmsix_table_mmio_write()におけるヒープバッファオーバーフロー(CVE-2020-27821)

- QEMU:e1000e:nullパケット記述子の場合の無限ループシナリオ(CVE-2020-28916)

- CVE-2020-29130 QEMU:slirp:ARP/NCSIパケットの処理中の領域外アクセス(CVE-2020-29129)

- CVE-2020-29129 QEMU:slirp:ARP/NCSIパケットの処理中の領域外アクセス(CVE-2020-29130)

- QEMU:ide:atapi:読み取りコマンドの処理中のOOBアクセス(CVE-2020-29443)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2021:1762

プラグインの詳細

深刻度: Medium

ID: 149772

ファイル名: centos8_RHSA-2021-1762.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2021/5/19

更新日: 2021/5/19

依存関係: ssh_get_info.nasl

リスク情報

CVSS スコアのソース: CVE-2020-25637

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS v3

リスクファクター: Medium

Base Score: 6.7

Temporal Score: 5.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:centos:centos:8, p-cpe:/a:centos:centos:SLOF, p-cpe:/a:centos:centos:hivex, p-cpe:/a:centos:centos:hivex-devel, p-cpe:/a:centos:centos:libguestfs-winsupport, p-cpe:/a:centos:centos:libiscsi, p-cpe:/a:centos:centos:libiscsi-devel, p-cpe:/a:centos:centos:libiscsi-utils, p-cpe:/a:centos:centos:libnbd, p-cpe:/a:centos:centos:libnbd-devel, p-cpe:/a:centos:centos:libvirt-dbus, p-cpe:/a:centos:centos:nbdfuse, p-cpe:/a:centos:centos:nbdkit, p-cpe:/a:centos:centos:nbdkit-bash-completion, p-cpe:/a:centos:centos:nbdkit-basic-filters, p-cpe:/a:centos:centos:nbdkit-basic-plugins, p-cpe:/a:centos:centos:nbdkit-curl-plugin, p-cpe:/a:centos:centos:nbdkit-devel, p-cpe:/a:centos:centos:nbdkit-example-plugins, p-cpe:/a:centos:centos:nbdkit-gzip-plugin, p-cpe:/a:centos:centos:nbdkit-linuxdisk-plugin, p-cpe:/a:centos:centos:nbdkit-python-plugin, p-cpe:/a:centos:centos:nbdkit-server, p-cpe:/a:centos:centos:nbdkit-ssh-plugin, p-cpe:/a:centos:centos:nbdkit-vddk-plugin, p-cpe:/a:centos:centos:nbdkit-xz-filter, p-cpe:/a:centos:centos:netcf, p-cpe:/a:centos:centos:netcf-devel, p-cpe:/a:centos:centos:netcf-libs, p-cpe:/a:centos:centos:ocaml-hivex, p-cpe:/a:centos:centos:ocaml-hivex-devel, p-cpe:/a:centos:centos:ocaml-libnbd, p-cpe:/a:centos:centos:ocaml-libnbd-devel, p-cpe:/a:centos:centos:perl-Sys-Virt, p-cpe:/a:centos:centos:perl-hivex, p-cpe:/a:centos:centos:python3-hivex, p-cpe:/a:centos:centos:python3-libnbd, p-cpe:/a:centos:centos:python3-libvirt, p-cpe:/a:centos:centos:ruby-hivex, p-cpe:/a:centos:centos:seabios, p-cpe:/a:centos:centos:seabios-bin, p-cpe:/a:centos:centos:seavgabios-bin, p-cpe:/a:centos:centos:sgabios, p-cpe:/a:centos:centos:sgabios-bin, p-cpe:/a:centos:centos:supermin, p-cpe:/a:centos:centos:supermin-devel

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/5/18

脆弱性公開日: 2020/7/23

参照情報

CVE: CVE-2020-11947, CVE-2020-16092, CVE-2020-25637, CVE-2020-25707, CVE-2020-25723, CVE-2020-27821, CVE-2020-28916, CVE-2020-29129, CVE-2020-29130, CVE-2020-29443

RHSA: 2021:1762