CentOS 8 : python-pillow (CESA-2021:4149)

critical Nessus プラグイン ID 155033

概要

リモートの CentOS ホストに 1 つ以上のセキュリティ更新プログラムが欠落しています。

説明

リモートのCentOS Linux 8ホストにインストールされているパッケージは、CESA-2021:4149 アドバイザリに記載されている複数の脆弱性の影響を受けます。

- python-pillow: PCX イメージリーダーにおけるバッファオーバーリード (CVE-2020-35653)

- python-pillow: SGI RLE イメージリーダーにおけるバッファオーバーリード (CVE-2020-35655)

- python-pillow: Out-of-bounds read in J2K 画像リーダーにおける領域外読み取り (CVE-2021-25287、CVE-2021-25288)

- python-pillow: TIFF 画像リーダーにおける Negative-offset memcpy (CVE-2021-25290)

- python-pillow: PDF フォーマットパーサーにおける正規表現の欠陥の DoS (CVE-2021-25292)

- python-pillow: SGI RLE 画像リーダーにおける領域外読み取り (CVE-2021-25293)

- python-pillow: BLP 画像リーダーにおける過大なメモリ割り当て (CVE-2021-27921)

- python-pillow: ICNS 画像リーダーにおける過大なメモリ割り当て (CVE-2021-27922)

- python-pillow: ICO 画像リーダーにおける過大なメモリ割り当て (CVE-2021-27923)

- python-pillow: PSD 画像リーダーにおける過大なメモリ割り当て (CVE-2021-28675)

- python-pillow: FLI 画像リーダーにおける無限ループ (CVE-2021-28676)

- python-pillow: EPS 画像リーダーでの過剰な CPU 使用 (CVE-2021-28677)

- python-pillow: BLP 画像リーダーにおける過大ループ (CVE-2021-28678)

- python-pillow: 画像変換機能におけるバッファオーバーフロー (CVE-2021-34552)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

影響を受けるpython3-pillowパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2021:4149

プラグインの詳細

深刻度: Critical

ID: 155033

ファイル名: centos8_RHSA-2021-4149.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2021/11/11

更新日: 2021/11/11

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-34552

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:python3-pillow

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/11/9

脆弱性公開日: 2021/1/12

参照情報

CVE: CVE-2020-35653, CVE-2020-35655, CVE-2021-25287, CVE-2021-25288, CVE-2021-25290, CVE-2021-25292, CVE-2021-25293, CVE-2021-27921, CVE-2021-27922, CVE-2021-27923, CVE-2021-28675, CVE-2021-28676, CVE-2021-28677, CVE-2021-28678, CVE-2021-34552

RHSA: 2021:4149