Foxit PDF Reader for Mac < 11.1.1 の複数の脆弱性

high Nessus プラグイン ID 157115

概要

リモート macOS ホストにインストールされた PDF ビューアーは、複数の脆弱性の影響を受けます。

説明

バージョン情報によると、リモート macOS ホストにインストールされている Foxit PDF Reader for Mac アプリケーション (旧称: Foxit Reader for Mac) は、11.1.1より前です。そのため、以下の複数の脆弱性の影響を受けます。

- Foxit PDF Reader for Mac に、特定の XFA ウィジェットの幅属性の処理中にアプリケーションがオブジェクトを適切に検証しないため、領域外読み取りエラーが存在します。認証されていないローカルの攻撃者が、これを悪用して、情報漏洩やクラッシュを引き起こす可能性があります。(CVE-2022-24370)

- Foxit PDF Reader for Mac に、ページが削除された後にアプリケーションがページ オブジェクトを適切なタイミングで削除できないため、領域外読み取りエラーが存在します。認証されていないローカルの攻撃者がこの脆弱性を悪用し、任意のコードを実行する可能性があります。(CVE-2022-24356)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

Foxit PDF Reader for Mac をバージョン11.1.1以降にアップグレードしてください

関連情報

http://www.nessus.org/u?a27a3e57

プラグインの詳細

深刻度: High

ID: 157115

ファイル名: macos_foxit_reader_11_1_1.nasl

バージョン: 1.7

タイプ: local

エージェント: macosx

公開日: 2022/1/26

更新日: 2022/8/16

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-24356

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:foxitsoftware:foxit_reader

必要な KB アイテム: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Foxit Reader

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/1/25

脆弱性公開日: 2022/1/25

参照情報

CVE: CVE-2022-24356, CVE-2022-24370

IAVA: 2022-A-0091-S