Debian DLA-2935-1: expat - LTS セキュリティ更新

critical Nessus プラグイン ID 158676

概要

リモートの Debian ホストに 1 つまたは複数のセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 9 ホストには、dla-2935 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 2.4.4より前の Expat (別名libexpat) では、XML_CONTEXT_BYTES がゼロでない構成の XML_GetBuffer に符号付き整数オーバーフローがあります。(CVE-2022-23852)

- 2.4.5より前の Expat (別名 libexpat ) の xmltok_impl.c には、UTF-8 文字が特定のコンテキストで有効かどうかのチェックなど、エンコーディングの特定の検証がありません。 (CVE-2022-25235)

- 2.4.5より前の Expat (別名 libexpat) の xmlparse.c により、攻撃者が名前空間 URI に名前空間セパレーター文字を挿入することが可能です。 (CVE-2022-25236)

- 2.4.5より前の Expat (別名 libexpat) では、攻撃者が DTD 要素のネストの深さを深くすることで、build_model でスタック枯渇を引き起こす可能性があります。(CVE-2022-25313)

- 2.4.5より前の Expat (別名 libexpat) では、storeRawNames に整数オーバーフローがあります。(CVE-2022-25315)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

expat パッケージをアップグレードしてください。

Debian 9 Stretch では、これらの問題はバージョン 2.2.0-2+deb9u5 で修正されています

関連情報

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1005894

https://security-tracker.debian.org/tracker/source-package/expat

https://www.debian.org/lts/security/2022/dla-2935

https://security-tracker.debian.org/tracker/CVE-2022-23852

https://security-tracker.debian.org/tracker/CVE-2022-25235

https://security-tracker.debian.org/tracker/CVE-2022-25236

https://security-tracker.debian.org/tracker/CVE-2022-25313

https://security-tracker.debian.org/tracker/CVE-2022-25315

https://packages.debian.org/source/stretch/expat

プラグインの詳細

深刻度: Critical

ID: 158676

ファイル名: debian_DLA-2935.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/3/7

更新日: 2022/5/25

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-25315

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:expat, p-cpe:/a:debian:debian_linux:lib64expat1, p-cpe:/a:debian:debian_linux:lib64expat1-dev, p-cpe:/a:debian:debian_linux:libexpat1, p-cpe:/a:debian:debian_linux:libexpat1-dev, cpe:/o:debian:debian_linux:9.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/3/7

脆弱性公開日: 2022/1/24

参照情報

CVE: CVE-2022-23852, CVE-2022-25235, CVE-2022-25236, CVE-2022-25313, CVE-2022-25315