Adobe Photoshop 22.x< 22.5.7/23.x < 23.3の複数の脆弱性 (APSB22-20)

high Nessus プラグイン ID 159666

概要

リモートWindowsホストにインストールされているAdobe Photoshopは、複数の脆弱性による影響を受けます。

説明

リモートWindowsホストにインストールされているAdobe Photoshopのバージョンは、22.5.7/23.3より前です。したがって、apsb22-20 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- Adobe Photoshop バージョン 22.5.6以前および 23.2.2以前は、領域外書き込みの脆弱性の影響を受けます。これにより、現在のユーザーのコンテキストで任意のコードが実行される可能性があります。
この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。
(CVE-2022-23205)

- Adobe Photoshop バージョン 22.5.6以前および 23.2.2以前は、PCX ファイルを解析する際に不適切な入力検証の脆弱性の影響を受けます。これにより、現在のユーザーのコンテキストで任意のコードが実行される可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のある PCX ファイルを開く必要があります。(CVE-2022-24098)

- Adobe Photoshop バージョン 22.5.6以前および 23.2.2以前は、領域外書き込みの脆弱性の影響を受けます。これにより、現在のユーザーのコンテキストで任意のコードが実行される可能性があります。
この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のある U3D ファイルを開く必要があります。
(CVE-2022-24105)

- Adobe Photoshop バージョン 22.5.6以前および 23.2.2以前は、領域外書き込みの脆弱性の影響を受けます。これにより、現在のユーザーのコンテキストで任意のコードが実行される可能性があります。
この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のある SVG ファイルを開く必要があります。
(CVE-2022-28270)

- Adobe Photoshop バージョン 22.5.6以前および 23.2.2以前は、メモリ解放後使用 (Use-After-Free) の脆弱性の影響を受けます。これにより、現在のユーザーのコンテキストで任意のコードが実行される可能性があります。
この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるPDFファイルを開く必要があります。
(CVE-2022-28271)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Adobe Photoshop バージョン22.5.7/23.3またはそれ以降にアップグレードしてください。

関連情報

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/125.html

https://cwe.mitre.org/data/definitions/416.html

https://cwe.mitre.org/data/definitions/787.html

https://helpx.adobe.com/security/products/photoshop/apsb22-20.html

プラグインの詳細

深刻度: High

ID: 159666

ファイル名: adobe_photoshop_apsb22-20.nasl

バージョン: 1.6

タイプ: local

エージェント: windows

ファミリー: Windows

公開日: 2022/4/12

更新日: 2022/5/18

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 6.9

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-28279

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:adobe:photoshop

必要な KB アイテム: installed_sw/Adobe Photoshop, SMB/Registry/Enumerated

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/4/12

脆弱性公開日: 2022/4/12

参照情報

CVE: CVE-2022-23205, CVE-2022-24098, CVE-2022-24105, CVE-2022-28270, CVE-2022-28271, CVE-2022-28272, CVE-2022-28273, CVE-2022-28274, CVE-2022-28275, CVE-2022-28276, CVE-2022-28277, CVE-2022-28278, CVE-2022-28279

IAVA: 2022-A-0148

CWE: 20, 125, 416, 787