Debian DLA-2988-1:tinyxml - LTS セキュリティ更新

high Nessus プラグイン ID 160409

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 9 ホストには、dla-2762 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- 2.6.2までの TinyXML には、TiXmlParsingData に無限ループがあります: : TIXML_UTF_LEAD_0 のケースを介した tinyxmlparser.cpp のスタンプ。これは細工された XML メッセージによってトリガーされ、サービス拒否を引き起こす可能性があります。
(CVE-2021-42260)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

tinyxml パッケージをアップグレードしてください。

Debian 9 Stretch では、この問題はバージョン 2.6.2-4+deb9u1 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/tinyxml

https://www.debian.org/lts/security/2022/dla-2988

https://security-tracker.debian.org/tracker/CVE-2021-42260

https://packages.debian.org/source/stretch/tinyxml

プラグインの詳細

深刻度: High

ID: 160409

ファイル名: debian_DLA-2988.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/5/2

更新日: 2022/5/2

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 3.6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-42260

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:libtinyxml-dev, p-cpe:/a:debian:debian_linux:libtinyxml-doc, p-cpe:/a:debian:debian_linux:libtinyxml2.6.2v5, p-cpe:/a:debian:debian_linux:libtinyxml2.6.2v5-dbg, cpe:/o:debian:debian_linux:9.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/4/30

脆弱性公開日: 2021/10/11

参照情報

CVE: CVE-2021-42260