CentOS 8: xorg-x11-server および xorg-x11-server-Xwayland (CESA-2022: 1917)

high Nessus プラグイン ID 160915

概要

リモートの CentOS ホストに 1 つ以上のセキュリティ更新プログラムが欠落しています。

説明

リモートの CentOS Linux 8 ホストにインストールされているパッケージは、CESA-2022: 1917 アドバイザリに記載されている複数の脆弱性の影響を受けます。

- xorg-x11-server: SProcRenderCompositeGlyphs の領域外アクセス (CVE-2021-4008)

- xorg-x11-server: SProcXFixesCreatePointerBarrier の領域外アクセス (CVE-2021-4009)

- xorg-x11-server: SProcScreenSaverSuspend の領域外アクセス (CVE-2021-4010)

- xorg-x11-server: SwapCreateRegister の領域外アクセス (CVE-2021-4011)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2022:1917

プラグインの詳細

深刻度: High

ID: 160915

ファイル名: centos8_RHSA-2022-1917.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/5/10

更新日: 2022/5/10

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-4011

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:xorg-x11-server-Xdmx, p-cpe:/a:centos:centos:xorg-x11-server-Xephyr, p-cpe:/a:centos:centos:xorg-x11-server-Xnest, p-cpe:/a:centos:centos:xorg-x11-server-Xorg, p-cpe:/a:centos:centos:xorg-x11-server-Xvfb, p-cpe:/a:centos:centos:xorg-x11-server-Xwayland, p-cpe:/a:centos:centos:xorg-x11-server-common, p-cpe:/a:centos:centos:xorg-x11-server-devel, p-cpe:/a:centos:centos:xorg-x11-server-source

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/5/10

脆弱性公開日: 2021/12/17

参照情報

CVE: CVE-2021-4008, CVE-2021-4009, CVE-2021-4010, CVE-2021-4011

RHSA: 2022:1917