Debian DLA-2998-1 : kicad - LTS security update

high Nessus プラグイン ID 160978

言語:

概要

リモートのDebianホストに1つまたは複数のセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 9 ホストには、dla-2998 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- KiCad EDA 6.0.1およびマスターコミット de006fc010 の Gerber Viewer ガーバーおよび excellon の ReadXYCoord 座標解析機能に、スタックベースのバッファオーバーフローの脆弱性が存在します。特別に細工されたガーバーまたはドリルファイルにより、コードが実行される可能性があります。攻撃者が悪意のあるファイルを提供してこの脆弱性を利用する可能性があります。(CVE-2022-23803)

- KiCad EDA 6.0.1およびマスターコミット de006fc010 の Gerber Viewer ガーバーおよび excellon の ReadIJCoord 座標解析機能に、スタックベースのバッファオーバーフローの脆弱性が存在します。特別に細工されたガーバーまたはドリルファイルにより、コードが実行される可能性があります。攻撃者が悪意のあるファイルを提供してこの脆弱性を利用する可能性があります。(CVE-2022-23804)

- KiCad EDA 6.0.1およびマスターコミット de006fc010 の Gerber Viewer ガーバーおよび excellon の GCodeNumber 解析機能に、スタックベースのバッファオーバーフローの脆弱性が存在します。特別に細工されたガーバーまたはドリルファイルにより、コードが実行される可能性があります。攻撃者が悪意のあるファイルを提供してこの脆弱性を利用する可能性があります。(CVE-2022-23946)

- KiCad EDA 6.0.1およびマスターコミット de006fc010 の Gerber Viewer ガーバーおよび excellon の DCodeNumber 解析機能に、スタックベースのバッファオーバーフローの脆弱性が存在します。特別に細工されたガーバーまたはドリルファイルにより、コードが実行される可能性があります。攻撃者が悪意のあるファイルを提供してこの脆弱性を利用する可能性があります。(CVE-2022-23947)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

kicad パッケージをアップグレードしてください。

Debian 9 Stretch では、これらの問題はバージョン 4.0.5+dfsg1-4+deb9u1で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/kicad

https://www.debian.org/lts/security/2022/dla-2998

https://security-tracker.debian.org/tracker/CVE-2022-23803

https://security-tracker.debian.org/tracker/CVE-2022-23804

https://security-tracker.debian.org/tracker/CVE-2022-23946

https://security-tracker.debian.org/tracker/CVE-2022-23947

https://packages.debian.org/source/stretch/kicad

プラグインの詳細

深刻度: High

ID: 160978

ファイル名: debian_DLA-2998.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/5/11

更新日: 2022/5/11

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-23947

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-common:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-ca:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-de:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-en:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-es:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-fr:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-it:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-ja:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-nl:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-pl:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:kicad-doc-ru:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/5/10

脆弱性公開日: 2022/2/4

参照情報

CVE: CVE-2022-23947, CVE-2022-23946, CVE-2022-23803, CVE-2022-23804