Slackware Linux 15.0/ current vim 複数の脆弱性 (SSA:2022-229-01)

high Nessus プラグイン ID 164261

概要

リモートの Slackware Linux ホストに、vim のセキュリティ更新プログラムがありません。

説明

リモートホストにインストールされている vim のバージョンは、8.2.4649 / 9.0.0223 より前です。したがって、SSA:2022-229-01 のアドバイザリに記載されている脆弱性の影響を受けます。

- 9.0.0211 より前の GitHub リポジトリ vim/vim における領域外読み取り。(CVE-2022-2816)

- 9.0.0212 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2817)

- 9.0.0210 より前の GitHub リポジトリ vim/vim におけるヒープベースのバッファオーバーフロー。(CVE-2022-2819)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受ける vim パッケージをアップグレードしてください。

プラグインの詳細

深刻度: High

ID: 164261

ファイル名: Slackware_SSA_2022-229-01.nasl

バージョン: 1.3

タイプ: local

公開日: 2022/8/18

更新日: 2022/12/6

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: AV:L/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-2819

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:slackware:slackware_linux:vim, p-cpe:/a:slackware:slackware_linux:vim-gvim, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

必要な KB アイテム: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

エクスプロイトの容易さ: No known exploits are available

脆弱性公開日: 2022/8/15

参照情報

CVE: CVE-2022-2816, CVE-2022-2817, CVE-2022-2819