Slackware Linux 15.0 / 最新版 vim の脆弱性 (SSA:2022-232-01)

high Nessus プラグイン ID 164325

概要

リモートの Slackware Linux ホストに、vim のセキュリティ更新プログラムがありません。

説明

リモートホストにインストールされている vim のバージョンは、8.2.4649 / 9.0.0231 より前です。したがって、SSA: 2022-232-01 のアドバイザリに記載されている脆弱性の影響を受けます。

- 9.0.0225より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2889)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存しています。

ソリューション

影響を受ける vim パッケージをアップグレードしてください。

プラグインの詳細

深刻度: High

ID: 164325

ファイル名: Slackware_SSA_2022-232-01.nasl

バージョン: 1.4

タイプ: local

公開日: 2022/8/22

更新日: 2023/10/13

サポートされているセンサー: Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.6

ベクトル: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2022-2889

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 7

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:slackware:slackware_linux:vim, p-cpe:/a:slackware:slackware_linux:vim-gvim, cpe:/o:slackware:slackware_linux, cpe:/o:slackware:slackware_linux:15.0

必要な KB アイテム: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

脆弱性公開日: 2022/8/19

参照情報

CVE: CVE-2022-2889