CentOS 8: php: 7.4 (CESA-2022: 6158)

high Nessus プラグイン ID 164418

概要

リモートのCentOSホストにセキュリティ更新プログラムがありません。

説明

リモートの CentOS Linux 8 ホストにインストールされているパッケージは、CESA-2022: 6158 のアドバイザリに記載されている脆弱性の影響を受けます。

- php: pg_query_params() の配列が初期化されていないため RCE が発生 (CVE-2022-31625)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2022:6158

プラグインの詳細

深刻度: High

ID: 164418

ファイル名: centos8_RHSA-2022-6158.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/8/25

更新日: 2022/8/25

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-31625

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.1

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:centos:centos:8, p-cpe:/a:centos:centos:apcu-panel, p-cpe:/a:centos:centos:libzip, p-cpe:/a:centos:centos:libzip-devel, p-cpe:/a:centos:centos:libzip-tools, p-cpe:/a:centos:centos:php-pear, p-cpe:/a:centos:centos:php-pecl-apcu, p-cpe:/a:centos:centos:php-pecl-apcu-devel, p-cpe:/a:centos:centos:php-pecl-rrd, p-cpe:/a:centos:centos:php-pecl-xdebug, p-cpe:/a:centos:centos:php-pecl-zip

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/8/24

脆弱性公開日: 2022/6/16

参照情報

CVE: CVE-2022-31625

RHSA: 2022:6158