DebianDLA-3092-1:dpdk - LTS セキュリティ更新

high Nessus プラグイン ID 164672

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3092 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

-入力の欠陥を許可する許容リストが DPDK で見つかりました。この問題により、リモート攻撃者が細工された Vhost ヘッダーを DPDK に送信することで、サービス拒否を引き起こす可能性があります。(CVE-2022-2132)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存しています。

ソリューション

dpdk パッケージをアップグレードしてください。

Debian 10 buster では、この問題はバージョン 18.11.11-1~deb10u2 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/dpdk

https://www.debian.org/lts/security/2022/dla-3092

https://security-tracker.debian.org/tracker/CVE-2022-2132

https://packages.debian.org/source/buster/dpdk

プラグインの詳細

深刻度: High

ID: 164672

ファイル名: debian_DLA-3092.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/9/3

更新日: 2022/9/7

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-2132

CVSS v3

リスクファクター: High

Base Score: 8.6

Temporal Score: 7.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:dpdk, p-cpe:/a:debian:debian_linux:dpdk-dev, p-cpe:/a:debian:debian_linux:dpdk-doc, p-cpe:/a:debian:debian_linux:dpdk-igb-uio-dkms, p-cpe:/a:debian:debian_linux:dpdk-rte-kni-dkms, p-cpe:/a:debian:debian_linux:libdpdk-dev, p-cpe:/a:debian:debian_linux:librte-acl18.11, p-cpe:/a:debian:debian_linux:librte-bbdev18.11, p-cpe:/a:debian:debian_linux:librte-bitratestats18.11, p-cpe:/a:debian:debian_linux:librte-bpf18.11, p-cpe:/a:debian:debian_linux:librte-bus-dpaa18.11, p-cpe:/a:debian:debian_linux:librte-bus-fslmc18.11, p-cpe:/a:debian:debian_linux:librte-bus-ifpga18.11, p-cpe:/a:debian:debian_linux:librte-bus-pci18.11, p-cpe:/a:debian:debian_linux:librte-bus-vdev18.11, p-cpe:/a:debian:debian_linux:librte-bus-vmbus18.11, p-cpe:/a:debian:debian_linux:librte-cfgfile18.11, p-cpe:/a:debian:debian_linux:librte-cmdline18.11, p-cpe:/a:debian:debian_linux:librte-common-cpt18.11, p-cpe:/a:debian:debian_linux:librte-common-dpaax18.11, p-cpe:/a:debian:debian_linux:librte-common-octeontx18.11, p-cpe:/a:debian:debian_linux:librte-compressdev18.11, p-cpe:/a:debian:debian_linux:librte-cryptodev18.11, p-cpe:/a:debian:debian_linux:librte-distributor18.11, p-cpe:/a:debian:debian_linux:librte-eal18.11, p-cpe:/a:debian:debian_linux:librte-efd18.11, p-cpe:/a:debian:debian_linux:librte-ethdev18.11, p-cpe:/a:debian:debian_linux:librte-eventdev18.11, p-cpe:/a:debian:debian_linux:librte-flow-classify18.11, p-cpe:/a:debian:debian_linux:librte-gro18.11, p-cpe:/a:debian:debian_linux:librte-gso18.11, p-cpe:/a:debian:debian_linux:librte-hash18.11, p-cpe:/a:debian:debian_linux:librte-ip-frag18.11, p-cpe:/a:debian:debian_linux:librte-jobstats18.11, p-cpe:/a:debian:debian_linux:librte-kni18.11, p-cpe:/a:debian:debian_linux:librte-kvargs18.11, p-cpe:/a:debian:debian_linux:librte-latencystats18.11, p-cpe:/a:debian:debian_linux:librte-lpm18.11, p-cpe:/a:debian:debian_linux:librte-mbuf18.11, p-cpe:/a:debian:debian_linux:librte-member18.11, p-cpe:/a:debian:debian_linux:librte-mempool-bucket18.11, p-cpe:/a:debian:debian_linux:librte-mempool-dpaa18.11, p-cpe:/a:debian:debian_linux:librte-mempool-dpaa2-18.11, p-cpe:/a:debian:debian_linux:librte-mempool-octeontx18.11, p-cpe:/a:debian:debian_linux:librte-mempool-ring18.11, p-cpe:/a:debian:debian_linux:librte-mempool-stack18.11, p-cpe:/a:debian:debian_linux:librte-mempool18.11, p-cpe:/a:debian:debian_linux:librte-meter18.11, p-cpe:/a:debian:debian_linux:librte-metrics18.11, p-cpe:/a:debian:debian_linux:librte-net18.11, p-cpe:/a:debian:debian_linux:librte-pci18.11, p-cpe:/a:debian:debian_linux:librte-pdump18.11, p-cpe:/a:debian:debian_linux:librte-pipeline18.11, p-cpe:/a:debian:debian_linux:librte-pmd-aesni-gcm18.11, p-cpe:/a:debian:debian_linux:librte-pmd-aesni-mb18.11, p-cpe:/a:debian:debian_linux:librte-pmd-af-packet18.11, p-cpe:/a:debian:debian_linux:librte-pmd-ark18.11, p-cpe:/a:debian:debian_linux:librte-pmd-atlantic18.11, p-cpe:/a:debian:debian_linux:librte-pmd-avf18.11, p-cpe:/a:debian:debian_linux:librte-pmd-avp18.11, p-cpe:/a:debian:debian_linux:librte-pmd-axgbe18.11, p-cpe:/a:debian:debian_linux:librte-pmd-bbdev-null18.11, p-cpe:/a:debian:debian_linux:librte-pmd-bnx2x18.11, p-cpe:/a:debian:debian_linux:librte-pmd-bnxt18.11, p-cpe:/a:debian:debian_linux:librte-pmd-bond18.11, p-cpe:/a:debian:debian_linux:librte-pmd-caam-jr18.11, p-cpe:/a:debian:debian_linux:librte-pmd-ccp18.11, p-cpe:/a:debian:debian_linux:librte-pmd-crypto-scheduler18.11, p-cpe:/a:debian:debian_linux:librte-pmd-cxgbe18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dpaa-event18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dpaa-sec18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dpaa18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dpaa2-18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dpaa2-cmdif18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dpaa2-event18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dpaa2-qdma18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dpaa2-sec18.11, p-cpe:/a:debian:debian_linux:librte-pmd-dsw-event18.11, p-cpe:/a:debian:debian_linux:librte-pmd-e1000-18.11, p-cpe:/a:debian:debian_linux:librte-pmd-ena18.11, p-cpe:/a:debian:debian_linux:librte-pmd-enetc18.11, p-cpe:/a:debian:debian_linux:librte-pmd-enic18.11, p-cpe:/a:debian:debian_linux:librte-pmd-failsafe18.11, p-cpe:/a:debian:debian_linux:librte-pmd-fm10k18.11, p-cpe:/a:debian:debian_linux:librte-pmd-i40e18.11, p-cpe:/a:debian:debian_linux:librte-pmd-ifc18.11, p-cpe:/a:debian:debian_linux:librte-pmd-ifpga-rawdev18.11, p-cpe:/a:debian:debian_linux:librte-pmd-ixgbe18.11, p-cpe:/a:debian:debian_linux:librte-pmd-kni18.11, p-cpe:/a:debian:debian_linux:librte-pmd-liquidio18.11, p-cpe:/a:debian:debian_linux:librte-pmd-mlx4-18.11, p-cpe:/a:debian:debian_linux:librte-pmd-mlx5-18.11, p-cpe:/a:debian:debian_linux:librte-pmd-netvsc18.11, p-cpe:/a:debian:debian_linux:librte-pmd-nfp18.11, p-cpe:/a:debian:debian_linux:librte-pmd-null-crypto18.11, p-cpe:/a:debian:debian_linux:librte-pmd-null18.11, p-cpe:/a:debian:debian_linux:librte-pmd-octeontx-compress18.11, p-cpe:/a:debian:debian_linux:librte-pmd-octeontx-crypto18.11, p-cpe:/a:debian:debian_linux:librte-pmd-octeontx-event18.11, p-cpe:/a:debian:debian_linux:librte-pmd-octeontx18.11, p-cpe:/a:debian:debian_linux:librte-pmd-opdl-event18.11, p-cpe:/a:debian:debian_linux:librte-pmd-openssl18.11, p-cpe:/a:debian:debian_linux:librte-pmd-pcap18.11, p-cpe:/a:debian:debian_linux:librte-pmd-qat18.11, p-cpe:/a:debian:debian_linux:librte-pmd-qede18.11, p-cpe:/a:debian:debian_linux:librte-pmd-ring18.11, p-cpe:/a:debian:debian_linux:librte-pmd-sfc18.11, p-cpe:/a:debian:debian_linux:librte-pmd-skeleton-event18.11, p-cpe:/a:debian:debian_linux:librte-pmd-skeleton-rawdev18.11, p-cpe:/a:debian:debian_linux:librte-pmd-softnic18.11, p-cpe:/a:debian:debian_linux:librte-pmd-sw-event18.11, p-cpe:/a:debian:debian_linux:librte-pmd-tap18.11, p-cpe:/a:debian:debian_linux:librte-pmd-thunderx18.11, p-cpe:/a:debian:debian_linux:librte-pmd-vdev-netvsc18.11, p-cpe:/a:debian:debian_linux:librte-pmd-vhost18.11, p-cpe:/a:debian:debian_linux:librte-pmd-virtio-crypto18.11, p-cpe:/a:debian:debian_linux:librte-pmd-virtio18.11, p-cpe:/a:debian:debian_linux:librte-pmd-vmxnet3-18.11, p-cpe:/a:debian:debian_linux:librte-pmd-zlib18.11, p-cpe:/a:debian:debian_linux:librte-port18.11, p-cpe:/a:debian:debian_linux:librte-power18.11, p-cpe:/a:debian:debian_linux:librte-rawdev18.11, p-cpe:/a:debian:debian_linux:librte-reorder18.11, p-cpe:/a:debian:debian_linux:librte-ring18.11, p-cpe:/a:debian:debian_linux:librte-sched18.11, p-cpe:/a:debian:debian_linux:librte-security18.11, p-cpe:/a:debian:debian_linux:librte-table18.11, p-cpe:/a:debian:debian_linux:librte-telemetry18.11, p-cpe:/a:debian:debian_linux:librte-timer18.11, p-cpe:/a:debian:debian_linux:librte-vhost18.11, cpe:/o:debian:debian_linux:10.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/9/2

脆弱性公開日: 2022/8/31

参照情報

CVE: CVE-2022-2132