Debian DLA-3087-1 : webkit2gtk - LTS security update

high Nessus プラグイン ID 164685

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3087 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- 境界チェックを改善することによって領域外書き込みの問題に対処しました。この問題は、iOS 15.6.1、iPadOS 15.6.1、macOS Monterey 12.5.1、Safari 15.6.1で修正されています。悪意を持って細工された Web コンテンツを処理すると、任意のコードが実行される可能性があります。Apple は、この問題が積極的に悪用された可能性があるという報告を認識しています。(CVE-2022-32893)

Nessusはこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

webkit2gtk パッケージをアップグレードしてください。

Debian 10 buster では、この問題はバージョン 2.36.7-1~deb10u1 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/webkit2gtk

https://packages.debian.org/source/buster/webkit2gtk

https://security-tracker.debian.org/tracker/CVE-2022-32893

https://www.debian.org/lts/security/2022/dla-3087

プラグインの詳細

深刻度: High

ID: 164685

ファイル名: debian_DLA-3087.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/9/6

更新日: 2022/12/6

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

リスク情報

VPR

リスクファクター: Critical

スコア: 9.2

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 8.7

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: CVSS2#E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-32893

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 8.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:gir1.2-javascriptcoregtk-4.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:gir1.2-webkit2-4.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libjavascriptcoregtk-4.0-18:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libjavascriptcoregtk-4.0-bin:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libjavascriptcoregtk-4.0-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libwebkit2gtk-4.0-37:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libwebkit2gtk-4.0-37-gtk2:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libwebkit2gtk-4.0-dev:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:libwebkit2gtk-4.0-doc:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:webkit2gtk-driver:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/9/5

脆弱性公開日: 2022/8/18

CISAの既知の悪用日: 2022/9/8

参照情報

CVE: CVE-2022-32893