Debian DLA-3110-1: glib2.0 - LTS セキュリティ更新

high Nessus プラグイン ID 165206

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3110 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- バージョン2.63.6より前の glib で欠陥が見つかりました。charset エイリアスがランダムであるため、pkexec が権限のあるユーザーが所有するファイルから権限のないファイルにコンテンツを漏洩する可能性があります。 (CVE-2021-3800)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存しています。

ソリューション

glib2.0 パッケージをアップグレードしてください。

Debian 10 buster では、この問題はバージョン 2.58.3-2+deb10u4 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/glib2.0

https://www.debian.org/lts/security/2022/dla-3110

https://security-tracker.debian.org/tracker/CVE-2021-3800

https://packages.debian.org/source/buster/glib2.0

プラグインの詳細

深刻度: High

ID: 165206

ファイル名: debian_DLA-3110.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/9/15

更新日: 2022/12/5

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 5.8

ベクトル: AV:N/AC:L/Au:N/C:C/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-3800

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:libglib2.0-0, p-cpe:/a:debian:debian_linux:libglib2.0-bin, p-cpe:/a:debian:debian_linux:libglib2.0-data, p-cpe:/a:debian:debian_linux:libglib2.0-dev, p-cpe:/a:debian:debian_linux:libglib2.0-dev-bin, p-cpe:/a:debian:debian_linux:libglib2.0-doc, p-cpe:/a:debian:debian_linux:libglib2.0-tests, cpe:/o:debian:debian_linux:10.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/9/15

脆弱性公開日: 2021/11/9

参照情報

CVE: CVE-2021-3800