DebianDLA-3116-1:mako - LTS セキュリティ更新

high Nessus プラグイン ID 165295

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 10 ホストには、dla-3116 のアドバイザリに記載された脆弱性の影響を受けるパッケージがインストールされています。

- 1.2.2 より前の Sqlalchemy mako は、Lexer クラスを使用して解析する際に、正規表現のサービス拒否に対して脆弱です。これは、babelplugin および linguaplugin にも影響を与えます。(CVE-2022-40023)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存しています。

ソリューション

mako パッケージをアップグレードしてください。

Debian 10 buster では、この問題はバージョン 1.0.7+ds1-1+deb10u1 で修正されています。

関連情報

https://security-tracker.debian.org/tracker/source-package/mako

https://www.debian.org/lts/security/2022/dla-3116

https://security-tracker.debian.org/tracker/CVE-2022-40023

https://packages.debian.org/source/buster/mako

プラグインの詳細

深刻度: High

ID: 165295

ファイル名: debian_DLA-3116.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/9/21

更新日: 2022/12/2

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 5.8

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-40023

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:python-mako, p-cpe:/a:debian:debian_linux:python-mako-doc, p-cpe:/a:debian:debian_linux:python3-mako, cpe:/o:debian:debian_linux:10.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/9/21

脆弱性公開日: 2022/9/7

参照情報

CVE: CVE-2022-40023