CentOS 8 : postgresql:12 (CESA-2022: 7128)

high Nessus プラグイン ID 166461

概要

リモートのCentOSホストにセキュリティ更新プログラムがありません。

説明

リモートの CentOS Linux 8 ホストにインストールされているパッケージは、CESA-2022: 7128 アドバイザリに記載されている脆弱性の影響を受けます。

- postgresql: - 拡張スクリプトが、該当する拡張に属さないオブジェクトを置換する (CVE-2022-2625)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://access.redhat.com/errata/RHSA-2022:7128

プラグインの詳細

深刻度: High

ID: 166461

ファイル名: centos8_RHSA-2022-7128.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2022/10/25

更新日: 2022/12/1

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 6.7

ベクトル: AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-2625

CVSS v3

リスクファクター: High

Base Score: 8

Temporal Score: 7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:centos:centos:8-stream, p-cpe:/a:centos:centos:pg_repack, p-cpe:/a:centos:centos:pgaudit, p-cpe:/a:centos:centos:postgres-decoderbufs, p-cpe:/a:centos:centos:postgresql, p-cpe:/a:centos:centos:postgresql-contrib, p-cpe:/a:centos:centos:postgresql-docs, p-cpe:/a:centos:centos:postgresql-plperl, p-cpe:/a:centos:centos:postgresql-plpython3, p-cpe:/a:centos:centos:postgresql-pltcl, p-cpe:/a:centos:centos:postgresql-server, p-cpe:/a:centos:centos:postgresql-server-devel, p-cpe:/a:centos:centos:postgresql-static, p-cpe:/a:centos:centos:postgresql-test, p-cpe:/a:centos:centos:postgresql-test-rpm-macros, p-cpe:/a:centos:centos:postgresql-upgrade, p-cpe:/a:centos:centos:postgresql-upgrade-devel

必要な KB アイテム: Host/local_checks_enabled, Host/CentOS/release, Host/CentOS/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/10/25

脆弱性公開日: 2022/8/11

参照情報

CVE: CVE-2022-2625

RHSA: 2022:7128

IAVB: 2022-B-0028-S